Tecnologia e non solo

aprile 3, 2012

Flash 11.2.202.228 blu? Workaround per driver Nvidia.

Filed under: Guida pericolosa,Video — telperion @ 10:21 pm

Il nuovo Flash 11.2.202.228 vi sfalsa i colori invertendo rosso e blu,
ovvero il famigerato puffo effect?

Avete un scheda nvidia con VDPAU e driver proprietari nvidia?

Un dev (?) nvidia ha preparato un workaround per libvdpau_trace.so
che se attivate l’opzione VDPAU_TRACE=1 con tale libreria provvede ad invertire i due colori.

Ovviamente dovete compilarvi libvdpau con la patch.

Se avete un sistema a 64bit recente potete usare la lib che ho compilato io su debian sid 64 bit:

trace-flash64.bit.zip 7.49KB

compilato con gcc 4.6 e libc6 2.13 64 bit

scompattate lo zip nella home, otterrete la cartella
trace-flash
che contiene
libvdpau_trace.so
libvdpau_trace.so.1.0.0

il primo è un link simbolico al secondo, che è la libreria trace modificata.

Ora dovete creare uno script di lancio per firefox tipo:

#!/bin/bash
LD_LIBRARY_PATH=/home/$NOME_VOSTRO_UTENTE/trace-flash
export LD_LIBRARY_PATH
export VDPAU_TRACE=1
firefox

ovviamente al posto di $NOME_VOSTRO_UTENTE mettete appunto il nome utente,
salvatelo in home, o dove vi pare.
Rendetelo eseguibile e usare questo script
(o puntare il lanciatore firefox allo script) per lanciare firefox.

Cosa fa lo script?
Imposta il path delle lib a guardare prima nella vostra cartella e poi in quelle di sistema, in questo modo, solo all’interno dello script, sarà caricata la libvdpau_trace.so modificata, mente il resto del sistema neppure sa che esiste questa lib.
Viene poi settata la variabile ambiente VDPAU_TRACE=1 sempre solo all’interno dello script, ed infine viene lanciato firefox con le due variabili ambiente così settate.

La facce torneranno rosa, i puffi blu e la cannella gialla


Uploaded with ImageShack.us

Con questo metodo non toccate nulla in /usr/lib, se reinstallate il driver nvidia non succede nulla, se volete rimuovere il tutto cancellate la cartella in home, lo script di lancio ed eventualmente ripristinate il lanciatore originale.

Se non avete capito nulla o avete un so linux troppo vecchio o a 32 bit lasciate perdere.
E sopratutto non ingoiate un cucchiaio di cannella.

😉

Appendice.
Con le ultime versioni del flash player è stata attivata una protezione che impedisce ai flash di leggere nella vostra cartella profilo.
Questo inibisce alcuni plugin ad esempio Foxtab.
Potete ripristinare l’accesso come prima, aggiungendo alla posizioni attendibili la cartella del vostro profilo come da immagine:


Uploaded with ImageShack.us

Annunci

marzo 28, 2009

dh_make per creare pacchetti deb.

Filed under: Attrezzi,Debian,Guida pericolosa,Pacchetti — telperion @ 6:04 pm

dh_make ci crea uno scheletro di partenza molto utile per creare pacchetti deb.
Ma “la domanda nasce spontanea”.

Come creare pacchetti deb che installano in /opt ?
Come creare pacchetti deb che installano file aggiuntivi ?
Come creare pacchetti deb che includono automaticamente le patch ?

Vediamo come utilizzare alcune funzioni che ci mette a disposizione il sistema di compilazione di pacchetti di debian.

(more…)

marzo 1, 2009

Migrare ad EXT4.

Filed under: Guida pericolosa — telperion @ 3:57 pm

Dopo gli aggiornamenti di una rolling,
o l’aggiornamento di versione di una Ubuntu,
potremmo avere tutto l’indispensabile per usare il nuovo filesystem ext4,
ma come fare per cambiare il “vecchio” ext3
senza dover reinstallare tutto daccapo perdendo tutto il nostro sudato “fine tuning”?


Facile con alcuni accorgimenti.

(more…)

settembre 6, 2008

C’è compilatore e compilatore.

Filed under: Debian,Guida pericolosa,Intrepid,Sid — telperion @ 4:04 pm

Aggiornamento 9/9/08

Con il compilatore gcc 4.3 alcuni programmi (esempio virtualbox-ose) non si compilano, è quindi necessario usare un’altra versione.

Su Gentoo esiste gcc-config che ci agevola come visto,
mentre nelle Debian based pare non ci sia nulla,
mi aspettavo un update-alternatives --config gcc, ma nulla.

E invece no.
Ma facciamo un passo indietro. Paura?!

(more…)

agosto 16, 2008

Grub? Gulp!

Filed under: Guida pericolosa — telperion @ 3:43 pm

Grub è sempre una fonte di problemi causa il suo complicato modo di numerare i dischi.
Provo a fare un po di luce sull’argomento senza aver la pretesa di spiegarvi tutto chiaramente, ma con la speranza di indicarci “il sentiero” per iniziare a capirci qualcosa.

(more…)

agosto 11, 2008

E.R. vcl-0.9.0-test3 sid: aggiornamento

Filed under: Debian,Guida pericolosa,Sid — telperion @ 11:41 pm

Abbiamo già visto come installare un vlc stand alone su debian sid,
con ffmpeg allegato per evitare le “complicazioni” di librerie in atto tra pacchetti debian e debian-multimedia.

immagine vlc-0.9.0-test3

È uscita in questi giorno la versione test3 di vlc-0.9.0 vediamo come compilarla.
(more…)

luglio 19, 2008

Gimp 2.5.x / svn e how-to

Filed under: Guida pericolosa,image-processing — telperion @ 2:11 pm

Nuovo snapshot della versione sperimentale di Gimp.

immagine gimp-2.5.2

Qualche trucchetto per compilarla in /opt/gimp-2.5
completa delle librerie di supporto per non interferire con il sistema come raccomandato
in http://gimp.org/release-notes/gimp-2.5.html

(more…)

luglio 12, 2008

E.R. vlc sid

Filed under: Debian,Guida pericolosa,Sid — telperion @ 9:39 am

Dopo gli strali contro le librerie condivise sul desktop, ecco una possibile soluzione per rianimare vlc, su sid con installato l’ffmpeg di debian-multimendia.

immagine vlc custom su sid

Ora non si sà bene come o perchè, compilare ed installare l’accoppiata ffmpeg e vlc
è un’operazione che o non và a buon fine o porta ad un vlc non funzionante come quello nel sistema.

L’unico “successo” lo ho raggiunto “replicando” l’installazione di gentoo ~x86 leggendomi gli ebuild, compilando ffmpeg e vlc che vengono installati in /opt/vlcmc e creando un “wrapper” vlcmc in /usr/local/bin in modo da avere un nuovo lettore senza intaccare il sistema.

(more…)

giugno 9, 2008

Icecream

Filed under: Debian,Gentoo,Guida pericolosa,Hardy,Sid — telperion @ 7:12 pm

Ho recentemente scoperto icecream (icecc) da questo blog e lo ho subito utilizzato con soddisfazione per effettuare “compilazioni distribuite”, oltre che per compilare kd4svn anche su Debian Sid e Gentoo per compilare qualsiasi cosa.

immagine icecc icemon
(more…)

aprile 28, 2008

Awn-trunk bzr: come compilarlo (Debian/Ubuntu) 3.a Edizione

Filed under: Debian,Gnome,Guida pericolosa,Gutsy,Hardy,Pacchetti,Sid,Temi — telperion @ 10:05 pm

Aggiornamento cambio nome pacchetto extras trunk del 27 nov 2007 (seconda edizione)
Aggiornamento cambio nome pacchetti awn-trunk del 24 nov 2007
Aggiornamento v.2.1 del 4 nov 2007 (prima edizione)

Ennesima edizione della guida aggiornata,
per compilare ed installare i pacchetti deb
di avant-window-navigator-trunk-bzr e delle extra applets,
con il mio metodo, che sicuramente non è l’unico,
probabilmente neppure il migliore,
ma visto che questo conosco, questo vi spiego.

awn-trunk-bzr
(more…)

Pagina successiva »