Tecnologia e non solo

marzo 26, 2008

Archlinux, mkinitcpio 0.5.18-1 (credo) e kernel fai da te.

Filed under: Archlinux — telperion @ 6:33 pm

L’ultimo mkinitcpio 0.5.18-1 sembra “problematico”.
Crea immagini corrette solo con i pacchetti del kernel ARCH scaricati.

Aggiornato il kernel26 2.6.24.3-6 nessun problema.

Compilato il vanilla 2.6.24.4 come sempre fatto, installato, reboot e:

ERROR: Failed to parse block device name for '/dev/sda6' unknown.
ERROR: root fs cannot be detected. Try using the rootfstype=...
Root device 'dev/sda7' doesn't exist, attempting to create root device '/dev/sda7'
ERROR: Failed to parse block device name for '/dev/sda6'
ERROR: Unable to create/detect root device '/dev/sda6'

kernel26vanilla-fallback uguale, nessun controller hd/cd rilevato.
(more…)

marzo 24, 2008

Archlinux gnome 2.22 gcc 4.3.0

Filed under: Archlinux — telperion @ 8:38 pm

Grossi aggiornamenti in Arch Linux.

Installati gcc-4.3.0 [core], libtool-2.2.2 [testing] relativi kernel26 e nvidia [testing] (installate prima kbd 1.14.1.20080309-2 [testing] o avrete errori) compilati con il nuovo compilatore.

Compilato con pkgbuild il kernel vanilla 2.6.24.3 [kernel26-vanilla] con relativa patch per il gcc-4.3.0
(/var/abs/testing/core/base/kernel26/fix-gcc43.patch se usate abs), e relativi moduli nvidia-vanilla 169.12-1 e virtualbox-modules-vanilla 1.5.6-1, tutto ok.

Installato da [testing] gnome gnome-extra (2.22.0) e poi tutto il resto, gstreamer-plugin in maggior parte, tranne openoffice-base. Al termine reinstallate gnome-settings-daemon per prevenire problemi dovuti allo spostamento di schemi da un pacchetto all’altro.

archlinux gome 2.22
(more…)

marzo 10, 2008

Compiz/Fusion: makefusion9 – script per compilazione.

Filed under: Archlinux,Compiz-core,Fusion,Gentoo,Gutsy,Hardy,Lenny,Sid — telperion @ 6:51 pm

Makefusion prima edizione: Giugno 2007
Makefusion9 prima edizione: Marzo 2008

AVVISO 8 febbraio 2009
Lo script non funziona, causa ennesimo cambio di tutto l’ambardan di compiz-fusion ora compiz++.
Se e quando la situazione si stabilizza vedrò se ho voglia di adattarlo.

Workaround provvisorio qui
(non più funzionante, solo se avete una versione dei sorgenti potete ricompilarla SENZA fare clone)

——————————————————–
Versione 9.036 ( 14 dicembre 2008 )
makefusion9.nnn.tar.gz (11 KB)
——————————————————–

Versione precedente makefusion8 qui.

——————————————————–
English version from Google Translate. Please read the code lines in the original version.
——————————————————–

Ultimi aggiornamenti:
– 14 dic 9.036 aggiornate dipendenze debian Sid e Lenny
– 18 nov 9.035 aggiunti plugin minimumize maximumizeplus putplus toggle-decoration swap
– 29 ott 9.032 aggiunto supporto preliminare Intrepid 8.10 (solo gnome e gtk NO KUBUNTU).
ATTENZIONE dopo ./makefusion9 packages solo con intrepid, alla fine vi verrà suggerito che pacchetti OpenGL installare a seconda dei driver che usate, purtroppo non so come farlo automaticamente.
– 30 ago avviso Plugin Animazioni diviso in 2. Leggere qui.
– 18 ago avviso Opzioni generali – Opacity settings sostituito dal plugin accessibilità – opacity brightness and saturation
– 14 lug 14.00 9.027 Aggiunto il plugin grid.
– 04 lug 18.00 9.026 Aggiunto il plugin stackswitch e gestione compilazione con cpu multicore (NCPU)
– 03 giu 14.30 9.024 release 0.7.2->0.7.6 Aggiunto supporto Kubuntu 8.04 Hardy Heron kde 3.5.x
– 28 apr 16.00 9.017 Aggiunto plugin workspace-naming
– 22 feb 18.00 I messaggi [ERROR] nell’uninstall.
error
Ignorateli tranquillamente.
Uninstall e clean vengono comunque eseguiti dallo script (la cartella ~/.compiz che contiene i plugin “sciolti” viene cancellata in ogni caso, e nei sorgenti la cartella build se presente).

——————————————————–

Questo script vi consente di scaricare compilare ed installare
le versione Git disponibile di Compiz-Fusion, e relativi tool e plugin,
su varie distribuzioni/architetture, e di aggiornarli successivamente quando possibile.
Questo script NON PRODUCE alcun tipo di pacchetto.
Compila installa e disinstalla con make.

(more…)

gennaio 29, 2008

Kernel headers 2.6.24 alla “frutta”

Filed under: Archlinux,Debian,Gutsy,Sid,Varie — telperion @ 11:04 pm

Sembra che la generazione degli headers del kernel con la 2.6.24
fallisca causa riunificazione architetture x86-32/64.

Sintomi:

in archlinux con il vanilla compilato (con PKGBUILD come da riferimento)
il link /usr/src/linux-2.6.24-vanilla/include/asm è interrotto
manca tutta la cartella
/usr/src/linux-2.6.24-vanilla/include/asm-x86
cartella che nei 2.6.23.x si chiamava /include/asm-i386

in debian sid con il vanilla (compilato con make-kpkg image headers)
il link /usr/src/linux-headers-2.6.24-mc/include/asm è interrotto
manca tutta la cartella
/usr/src/linux-headers-2.6.24-mc/include/asm-x86
cartella che nei 2.6.23.x si chiamava /include/asm-i386

Come conseguenza non si compila più nulla senza tutto il source del kernel.

Esempi:

https://telperion.wordpress.com/2008/01/27/kernel-2624-e-nvidia-169-09/

http://forum.debianizzati.org/kernel/linux-2624-vboxdrv-build-fallito-t32356.0.html

http://bbs.archlinux.org/viewtopic.php?id=43045

Se qualcuno ha notizie … notizi.

PS:

Su ArchLinux usando il nuovo schema PKGBUILD del kernel26-ARCH 2.6.24 in testing
come riferimento, che varia parecchio dal “vecchio” standard tutto và a posto, a conferma
che è il kernel che è cambiato negli headers.
Non ho idea di come ottenere gli headers corretti su Debian Ubuntu con make-kpkg.

headers archlinux

Gli headers corretti su Arch Linux

Io, 2 palle
non sò più in che lingua scriverlo.

Tech:

2.13. x86-32/64 arch reunification

You can read this recommended article.

When support for the x86-64 AMD architecture was developed, it was decided to develop it as a “fork” of the traditional x86 architecture for comodity reasons. Many patches needed to patch a file in the i386 architecure directory, and another similar patch for the duplicated file in the x86_64 directory. It has been decided to unify both architectures in the same directory again.

This reunification has not been done in a radical way. In this release, both architectures have been unified in arch/x86, but only in appearance. All the source files in i386 and x86-64 directories have been moved to arch/x86, but renaming them with “_32” and “_64” suffixes. Ex: arch/i386/kernel/reboot.c has been moved to arch/x86/kernel/reboot_32.c, and arch/x86_64/kernel/reboot.c has been moved to arch/x86/kernel/reboot_64.c. Makefiles have been modified accordingly. So for now the reunification has been pretty much just a relocation of all the files and adaptation of the build machinery to make it compile just as it’d have been compiled in the old separated directories, done mostly with scripts.

In the future lots of those files will be unified and shared by both architectures, ex. reboot_32.c and reboot_64.c into reboot.c, and many files have already been unified in this release. Others will keep separated forever, due to the differences between both architectures.

gennaio 22, 2008

Pasticcini e pasticcioni.

Filed under: Archlinux,Varie — telperion @ 4:57 pm

Se con il recente aggiornamento di ffmpeg su arch linux (e solo su arch linux),
vlc (di nuovo!) non apre più file avi con il messaggio da terminale:

main decoder error: no suitable decoder module for fourcc `XVID'.

bene siete vittime dell’ennesimo “pasticcio”.

Se ne esce fuori in maniera non proprio semplice con questa discussione del forum internazionale.
La soluzione, testata e funzionante che consiste nel ricompilare ffmpeg con l’opzione

--disable-swscaler

e poi vlc applicando questa patch,
oppure compilate un vlc-nightfly come suggerito da damir (thx).

Che 2 palle!

Condividerei i pacchetti ma sono ottimizzati per athlon-xp.

gennaio 18, 2008

Vlc e xorg-server 1.4.0.90-4/1.4.0.90.r1

Filed under: Archlinux,Gentoo,Varie — telperion @ 7:58 pm

Su archlinux
xorg-server 1.4.0.90-4
* Su archlinux corretto (con ritardo) da xorg-server-1.4.0.90-5

e su gentoo
xorg-server 1.4.0.90-r1
* Su gentoo corretto da xorg-server-1.4.0.90-r2

e su Debian sid

provocano il mancato funzionamento dell’interfaccia wxwindows
di vlc (cvlc da terminale funziona invece) sia versione 0.8.6d che 0.9alpha

vlc
(more…)

ottobre 27, 2007

Fusion: nuovo script per compilazione.

prima edizione: Giugno 2007

——————————————————–
Il nuovo makefusion9 qui.
——————————————————–

Versione 8.078 (ultima di makefusion8, lo sviluppo continua con makefusion9)
makefusion8.nnn.tar.gz (11 KB) MIRROR RapidShare

——————————————————–

Ultimi aggiornamenti:
– 03 mar 17.00 8-078 Ubuntu Hardy Heron Gnome: workaround definitivo per ovviare ai problemi del pacchetto libcompizconfig0 installato di default che non si può rimuovere; ora si compila anche il gtk-wd e viene creato un divert libcompizconfig0 per evitare interferenze e ripristinare la situazione precedente nella fase “uninstall”.
Migliorati messaggi della versione dello script.
– 02 mar 17.00 8-075 – Su “ubuntu-hardy” forzata la compilazione della “master” e disattivata la compilazione del gtk-window-decorator a causa di dipendenze circolari dei pacchetti ubuntu hardy heron.
Per tutte le altre distribuzioni non cambia nulla tutto regolare.

– 25 feb 17.00 8-073 aggiunto supporto Ubuntu Hardy Heron 8.04 Gnome
– 22 feb 18.00 Spiegato con maggiore chiarezza nel change log v8.068,
la totale irrilevanza dei messaggi [ERROR] nell’uninstall.
error
Ignorateli tranquillamente.
Uninstall e clean vengono comunque eseguiti dallo script (la cartella ~/.compiz che contiene i plugin “sciolti” viene cancellata in ogni caso, e nei sorgenti la cartella build se presente).

– 08 feb 14.50 v8.072 – aggiunta dipendenza libnotify-dev per il plugin notify ora in plugin-extra insieme a shelf e maximumize.Installate il pacchetto libnotify-dev o rieseguite ./makefusion8 packages
In plugin-main showmouse mousepoll e magnify glass. Aggiornate le info per compiz 0.7.x.
– 29 gen 16.59 v8.069: aggiunto --disable-kde4 anche alla configurazione gnome, visto che se presenti le qt4 nel sistema, compiz cerca di compilare kde4-wd con conseguente errore (ma attivarlo SOLO con l’opzione ENABLE no eh?!)
– 28 gen 16.00 v8.068 migliorato uninstall (clean) di alcuni nuovi plugin (non preoccupatevi delle segnalazioni [ERROR] ignoratele, in realtà viene tutto disinstallato correttamente e viene anche eseguito il clean dei sorgenti) e il make di anaglyph con “master-xcb” che falliva per presenza della cartella anaglyph-0.6
– 28 gen 01.00 v.8.067 eliminata la compilazione di kde4-wd che crea problemi in “master-noxcb” in sistemi con kde3+kde4 installati. Irrilevante per chi ha gnome o kde3.5.x. Aggiunti alcuni plugin
– 03 gen 21.00: v.8.065 aggiunta dipendenza KDE python-gtk2 (comm. 381-382) ,
eliminata in archlinux mesa, dovete installare mesa o libgl a seconda della scheda video che avete (comm. 383-384), per mesa e nvidia su archlinux vedi anche 387-388.
– 17 nov 17.00: v 8.062 aggiunto atlantis2 (master noxcb)
– 12 nov 11.00: v 8.061 aggiunto supporto Fedora 8 Gnome (tnx LuNa)
– 05 nov 14.30: v 8.057 aggiunto photowheel (solo master o master-noxcb)
– 30 ott 11.00: v 8.055 kde: per visualizzare le icone nel ccsm bisogna installare librsvg2-common aggiunto alle dipendenze.
– 27 ott 00.00: v 8.052 aggiunto freewins (solo master o master-noxcb)

——————————————————–

Questo script vi consente di scaricare compilare ed installare
le versione Git disponibile di Compiz-Fusion, e relativi tool e plugin,
su varie distribuzioni/architetture, e di aggiornarli successivamente quando possibile.
Questo script NON PRODUCE alcun tipo di pacchetto.
Compila installa e disinstalla con make.

(more…)

ottobre 23, 2007

Virtualbox 1.5.2 e moduli kernel.

Filed under: Archlinux,Debian,Feisty,Gutsy,Lenny,Sid,Varie — telperion @ 11:37 pm

Come segnalato da Antonio Doldo
potete aggiornare Virtualbox anche su Gusty seguendo le sue indicazioni.

Volevo solo cercare di chiarire la situazione confusa dei moduli del kernel.

Virtualbox 1.5.2

Esistono 2 versiono di Virtualbox una open source edition (ose)
e l’altra non os e per uso privato.
(more…)

ottobre 15, 2007

Flash del 15 ottobre

Filed under: Archlinux,Gutsy,Sid,Varie — telperion @ 6:22 pm

Gutsy: Kde 3.5.8
Sid: Kde 3.5.8
Archlinux: Kde 3.5.8, Gnome 2.20 in extra

kde 3.5.8

Su kde.org nessuna traccia di annunci.
Vabbè che tutti aspettano il 4,
e il 3.5 sembra diventato “roba da rottamare”,
però …

🙂

Annuncio.
Kde 3.5.8 changelog

ottobre 6, 2007

Avant window navigator

Filed under: Archlinux,Debian,Etch,Feisty,Gutsy,Lenny,Sid,Temi,Varie — telperion @ 2:21 pm

Giunto alle versioni avant-window-navigator-bzr125 e awn-core-applets-bzr83

Avant window navigator

i nuovi effetti disponibili
sono ora applicabili singolarmente ai singoli eventi sulla barra.

avant window navigator
(more…)

« Pagina precedentePagina successiva »