Tecnologia e non solo

agosto 26, 2011

Compiz-plugin-extra 0.8.x e libnotify4 0.7

Filed under: Compiz-core,Debian,Gnome,Sid — telperion @ 1:55 pm

Con le nuove notifiche libnotify4 0.7, se volete compilare Compiz-plugin-extra 0.8.x, otterrete errore in src/notification/notification.c

Basandomi sul commit del plugin della versione 0.9.x, ho ricavato la patch per compilarlo regolarmente:

--- a/src/notification/notification.c	2011-07-25 13:51:02.000000000 +0200
+++ b/src/notification/notification.c	2011-08-26 14:37:26.909291358 +0200
@@ -104,9 +104,6 @@
     n = notify_notification_new (logLevel,
                                  message,
                                  iconUri
-#if !defined (HAVE_LIBNOTIFY_0_6_1)
-                                 , NULL
-#endif
                                  );
 
     notify_notification_set_timeout (n, nd->timeout);
Annunci

%d blogger hanno fatto clic su Mi Piace per questo: