Tecnologia e non solo

agosto 20, 2009

Tearing, tearing, tearing.

Filed under: Archlinux — telperion @ 1:38 pm

Tearing..
Dannato maledetto tearing.

Compilati su archlinux, come di consueto, xbmc, smplayer e mplayer con supporto VDPAU.
Stessa configurazione che con Ubuntu 9.04, stesso driver Nvidia 190.18,
provato anche con lo “stabile” 185.18.31, con compiz e metacity, con kde4 e kwin, risultato?

Tearing a vagoni,
tearing e ancora tearing, impossibile guardare qualsiasi cosa sul tv o sul monitor.

[mc@mc-arch ~]$ pacman -Qs xorg-server
local/xorg-server 1.6.3-3 (xorg)
X.Org X servers
local/xorg-server-utils 7.4-7 (xorg)
X.Org utilities required by xorg-server

VS

Che sia l’imputato?

*AGGIORNAMENTO.
Su Gentoo~x86 xorg è alla versione 1.6.3, nessun tearing, nessuno. Il problema è solo su archlinux.

Possibile che “niente” sia mai uguale a “niente”,
ed il risultato finale, sia sempre un terno al lotto?

*%$##*&&£$£”### !!!!!

15 commenti

  1. Eh ma mi hanno detto che i developers hanno fatto una cazzata riguardante mplayer e VDPAU, occhio agli aggiornamenti.

    Commento di Bl@ster — agosto 20, 2009 @ 2:56 pm

    • Intendi su xorg?
      Perchè il resto lo compilo io, quindi i developers possono fare ben poco …

      Commento di telperion — agosto 20, 2009 @ 4:50 pm

  2. Può darsi che i driver nvidia non siano ancora “pronti” per xorg 1.6.3

    Commento di guiodic — agosto 20, 2009 @ 10:00 pm

    • p.s. provato il sync to vblank in compiz?

      p.p.s. Viva Intel, 0 tering con i nuovi driver 2.8😉

      Commento di guiodic — agosto 20, 2009 @ 10:02 pm

      • Provato tutto, anche spegnendo compiz, il problema resta, penso che dipenda da xorg o da come è stato compilato dai mantainers.
        Stessa cosa con kde4 con kwin con o senza effetti.
        Da notare che con Ubuntu 9.04 è tutto perfetto.
        É deprimente la montagna di problemi che ci sono sempre …

        Commento di telperion — agosto 21, 2009 @ 7:34 am

  3. Ormai ci ho fatto l’abitudine vedo tyearing sul cubo di compiz come su qualsiasi video, neanche con i catalyst 9.8 hanno risolto sto problema, vabbe speriamo nelle prossime versioni dell’xorg, dei drivers e delle distro

    Commento di Markus — agosto 20, 2009 @ 11:57 pm

    • Il tearing sul cubo, non è particolarmente fastidioso, mentre nella visione di un film è veramente insopportabile.

      Commento di telperion — agosto 21, 2009 @ 7:36 am

  4. Quindi a quanto vedo è un problema solo di arch.

    Commento di guiodic — agosto 22, 2009 @ 4:04 pm

    • Si, accade solo su archlinux.

      Commento di telperion — agosto 22, 2009 @ 4:47 pm

  5. No, ho lo stesso problema anche su Ubuntu 9.04 con i drivers ati 9.10.

    Commento di Riccardo — ottobre 25, 2009 @ 2:38 pm

    • Vabbè Ati è un’altra parocchia, che c’entra?
      Sono arcinoti (nel senso che ci sono migliaia di lamentele) i problemi di tearing su ati.

      Commento di telperion — ottobre 25, 2009 @ 2:57 pm

  6. ho lo stesso problema su Gentoo (da quando ho fatto l’upgrade xorg-server 1.5 => 1.6)

    xorg-server-1.6.3.901-r2 e nvidia-drivers-180.60

    purtroppo ancora nessuna soluzione😦

    Commento di 0xF00C0DE — ottobre 29, 2009 @ 7:59 pm

  7. Telperion, hai per caso trovato una qualche soluzione a sta cosa?
    anche io Arch64 + XBMC-svn r25523 + nvidia 195.22 (su 8600m GT) e stesso problema…

    Commento di berseker — dicembre 13, 2009 @ 10:39 am

    • @berseker
      è un po che non uso archlinux proprio per il tearing, che su ubuntu e debian invece non ho, appena ho tempo provo col nuovo xorg e gli ultimi nvidia e ti dico.

      Commento di telperion — dicembre 13, 2009 @ 1:27 pm

  8. vedo che sul pacchetto xorg-xserver in arch viene applicata una fantomatica nvidia-performance.patch.. http://repos.archlinux.org/wsvn/packages/xorg-server/repos/extra-x86_64/ chissà perchè ho una vaga sensazione..

    Commento di berseker — dicembre 13, 2009 @ 5:11 pm


RSS feed for comments on this post.

Crea un sito o un blog gratuitamente presso WordPress.com.

%d blogger cliccano Mi Piace per questo: