Tecnologia e non solo

febbraio 4, 2009

Con GoogleEarth 5 …

Filed under: Edicola,Internet,Varie — telperion @ 3:14 pm

iammo’n’coppa o’Vesuvio!
(I napoletani mi perdonino😀 )


É disponibile la versione 5 beta, di un programma sempre più bello.
Per i dettagli delle novità vedete il sito.

Risoluzione problemi vari (aggiornato 5 febbraio):

Note tecniche,
se non parte lanciatelo da terminale,
se vi dice
symbol lookup error /usr/lib/libssl.so.0.9.8
allora rinominate (Googleearth installato in /opt/google-earth negli esempi)

/opt/google-earth/libcrypto.so.0.9.8
in
/opt/google-earth/_libcrypto.so.0.9.8

In qualche caso, anche con Googleearth 4.3, i font piccoli potrebbero non essere visualizzati, al loro posto vedrete dei quadratini vuoti.
Anche in questo caso problemi di compatibilità delle lib Qt4 di GE con quelle installate nel sistema.

Rinominate
/opt/google-earth/libQtCore.so.4
in
/opt/google-earth/_libQtCore.so.4

e
/opt/google-earth/libQtGui.so.4
in
/opt/google-earth/_libQtGui.so.4

e passa la paura.

AGGIORNAMENTO:
altra possibilità (consigliata) in caso di problemi con i font.

Controllate il vostro xorg.conf
e nella sezione “Files” e verificate che i path dei font installati nel vostro sistema siano corretti e tutti presenti.
Nel mio caso ne mancavano parecchi, ora è cosi:

Section "Files"

	# path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/share/fonts/corefonts"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/share/fonts/default"
    FontPath        "/usr/share/fonts/encodings"
    FontPath        "/usr/share/fonts/liberation-fonts"
    FontPath        "/usr/share/fonts/OTF"
    FontPath        "/usr/share/fonts/Speedo"
    FontPath        "/usr/share/fonts/truetype"
    FontPath        "/usr/share/fonts/TTF"
    FontPath        "/usr/share/fonts/ttf-bitstream-vera"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/share/fonts/util"
    # FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Ora i font ci sono tutti

mc@ ~ $ ls /usr/share/fonts
100dpi     cyrillic   liberation-fonts  Speedo    ttf-bitstream-vera
75dpi      default    misc              truetype  Type1
corefonts  encodings  OTF               TTF       util

Riavviate il server X e googleearth funzionerà perfettamente con le proprie librerie libqt4*.

Vidooo’mare quant’eeebeeeeelloooo,
spira tanto sentimentoooooooooooo …

😀

17 commenti

  1. Hai mica provato la modalita “alla scoperta del pianeta” ? A me si fionda da un luogo all’altro senza apparente senso, tanto velocemente che non carica manco le texture!😀

    Commento di Reload — febbraio 4, 2009 @ 5:48 pm

  2. Beh quello che vedi è “alla scoperta del pianeta”
    ho cliccato su “mount Vesuvius” ho cambiato inquadratura, messo le nubi gli oceani, tolti i pallini di troppo e *cheese* ho scattato a foto.😀

    Commento di telperion — febbraio 4, 2009 @ 5:55 pm

  3. Pero non hai le spunta sul vesuvio! O l’hai tolta prima dello scree?😛

    Commento di Reload — febbraio 4, 2009 @ 8:12 pm

  4. @reload
    doppio click sul nome nella lista.

    Commento di telperion — febbraio 4, 2009 @ 8:21 pm

  5. Non è la stessa cosa io parlo del tour che viene riprodotto spignendo sull’apposito pulsante… boh cmq stica😀

    Commento di Reload — febbraio 4, 2009 @ 10:31 pm

  6. L’avevo installato 2 giorni fa ma non funzionava a causa dell’errore di quella libreria.

    Per fortuna che ci sei tu.😛

    Commento di Piplos — febbraio 5, 2009 @ 12:05 am

  7. lo provo appena torno dal dark side of the moon (l’ennesimo)
    PS= lo stesso articolo con gli stessi consigli sta anche in quell’ ALTRO blog. stavolta chi copia da chi o avete copiato tutti e 2😛

    Commento di LuNa — febbraio 5, 2009 @ 5:59 pm

  8. @LuNa
    la libssl.so era su un forum opensuse il 2 febbario.

    Le libqt rinominate l’ho trovato da me rinominando una ad una le lib di GE per vedere se riuscivo a riavere i font su gentoo.
    Con le qt del sistema finalmente avevo i font, in compenso no caricava più le foto di panoramio.

    In ultimo il suggerimento dell’ xorg.conf arriva da bugs gentoo

    http://bugs.gentoo.org/show_bug.cgi?id=252419

    che a fronte di caratteri meno belli che con le qt di sistema mi permette di caricare le foto, per cui tengo quello.

    Tali comportamenti credo dipendano da diverse versioni di qt4
    ed xorg-server in varie combinazioni.

    Il solito casino.

    “È Linux bellezza” (cit.)

    Per il resto non mi interessa.
    Io divulgo quel che so, lo stesso credo faccia Felipe.

    Commento di telperion — febbraio 5, 2009 @ 6:20 pm

  9. Anche a me se uso le lib di sistema non vedo le foto, e dipende di sicuro dal fatto che ci sono versioni differenti delle qt4. Infatti spippolando un po ero riuscito a creare un casino tale da farmi dire esplicitamente da ge che era in atto un cozzamaento di versioni diverse…lol

    Morale mi tengo i caratteri urendi

    Commento di Reload — febbraio 6, 2009 @ 3:21 pm

  10. a me non parte, per nessuno dei motivi citati qui.
    se lo lancio da utente mi dice che non puo’ scrivere in /root/.googleearth (perchè cribbio vuoi scrivere in root se sono utente lo sa dio)
    l’unica volta che ha tirato a partire ho ottenuto questo:

    Google Earth has caught signal 11.
    Another crash happened while handling crash!

    ovvero c’e’ scritto che il gestore dei crash è andato in crash O_O

    “E’ Linux bellezza” (cit. di cit.)😉

    Commento di LuNa — febbraio 7, 2009 @ 2:51 pm

  11. LuNa
    quello succede se lo lanci una volta da su

    Devi rimuovere poi
    ~/.google ~/.config/Google ~/.config/Trolltech.conf

    Commento di telperion — febbraio 7, 2009 @ 3:08 pm

  12. @telperion: cancellate cartelle da te consigliate, primo problema sparito🙂 e gracias ancora una volta🙂
    rimane ancora

    Google Earth has caught signal 11.
    Another crash happened while handling crash!

    in pratica vedo soltanto lo splash screen iniziale, e poi questo. da goooooooooooooogle ho trovato diverse soluzioni (almeno 3) che ho applicato senza alcun risultato
    ma porcaccia, ora ci metto quello per windows sotto wine e funziona alla prima :S
    se hai altri suggerimenti🙂

    Commento di LuNa — febbraio 7, 2009 @ 5:22 pm

  13. @LuNa
    No niente altro tranne che l’user deve sessere nel gruppo “video”.

    Il crash quando si “maneggia” il crash, giuro non l’avevo mai visto. Giusto a te poteva accadere …
    Forse un problema con i 64 beatles?

    A me funziona su tutti i sistemi, Gentoo il più “rognoso” che mi ha costretto a scrivere il path di tutti i font nello xorg.conf.
    Gli altri solo la libcrypto (debian arch)

    LOL

    Commento di telperion — febbraio 7, 2009 @ 6:07 pm

  14. @telperion: no, non succede solo a me, se guardi google succede a molti, ma di possibili soluzioni ce ne sono veramente tante.
    about 64 beatles: no, sto a 32🙂
    sulla debian non ho provato, ma lo farò presto, altrimenti vado di vino🙂

    Commento di LuNa — febbraio 7, 2009 @ 8:31 pm

  15. arrivato in portage

    Available versions: 4.2.205.5730!m!s (~)4.3.7284.3916!m!s (~)5.0.11337.1968_beta!m!s

    installato e funzionante nessun crash. con il .bin niente. mah. poi guardo l’ebuild, magari ci sta qualche “tip” che mi è sfuggito.

    Commento di LuNa — febbraio 9, 2009 @ 9:16 am

  16. tutto ok con i font…o meglio dopo un pò di modifiche…ora leggo perfettamente,solo…incontro un piccolo problema,non so se sia capitato a qualcuno di voi,ma è davvero fastidioso…ad un certo punto di zoom tutto diventa…celeste!arrivati diciamo ai 3 km di quota il mondo diventa celeste e niente di niente oltre che celeste…ovunque…qualcuno sa darmi una qualche dritta?

    Commento di Dw — febbraio 11, 2009 @ 4:36 pm

  17. @dw
    forse non scarica le mappe, monitorizza la connessione vedi se scarica dati, altrimenti prova a ripristinare le libqt4* di GG e vedi se funziona. Ancora cancella le cartelle indicate nel commento 11, altro non so.
    A me mai successo.

    Commento di telperion — febbraio 11, 2009 @ 5:12 pm


RSS feed for comments on this post.

Crea un sito o un blog gratuitamente presso WordPress.com.

%d blogger cliccano Mi Piace per questo: