Tecnologia e non solo

febbraio 7, 2008

Compiz 0.7.0 release

Filed under: Compiz-core — telperion @ 4:54 pm

Comunicato ufficiale.

Ora nel git master si compila compiz-0.7.1

compiz 0.7.1

Novità poche rispetto alla 0.6.x le leggete nel comunicato.
Nessuna rispetto alla git master 0.5.5

Neppure la prossima versione object-framework prevede sostanziali novità per gli utenti finali,
prevedendo solo la riscrittura delle interfacce dei plugin, consentendo una più facile scrittura e gestione dei medesimi. Insomma roba per “developers” per noi utilizzatori a parte il caos coi plugin rotti che provocherà nel momento in cui verrà introdotta, cambierà nulla.

Info sulla object-framework:
http://lists.freedesktop.org/archives/compiz/2007-December/002874.html
http://lists.freedesktop.org/archives/compiz/2007-December/002875.html

La 0.7.1 si compila con “master” o “master-noxcb” con lo script makefusion8.

8 commenti

  1. ma porca miseria!!!

    la 0.5.5 era la versione di sviluppo e la 0.6 quella stabile(alla faccia della razionalità)

    adesso la 0.6 è stata sostituita dalla 0.7 e la 0.5.5 è ancora quella di sviluppo o che?

    Commento di simo_magic — febbraio 7, 2008 @ 5:05 pm

  2. i rami sono
    vecchio compiz senza xcb
    0.5.2 -> 0.6 -> 0.6.0 -> 0.6.2 -> STOP MORTO FINE

    nuovo compiz con xcb (per ora facilmente revertibile no-xcb)
    0.5.3 -> 0.5.4 -> 0.5.5 -> 0.7.0 -> 0.7.1 (master)

    in grassetto le release,
    non mi sembra tanto complicato, dopo la 0.5-3 si è forkato in 2 rami uno con xcb
    uno senza visto che le maggiori distribuzioni ancora non lo adottano.
    Il ramo senza xcb 0.6.x è finito, capolinea, l’altro va avanti.

    Commento di telperion — febbraio 7, 2008 @ 5:13 pm

  3. Ce l’ho anch’io, ce l’ho anch’io!!!

    simo però non ha tutti i torti…ma basta tener presente che le stabili sono quelle con pari alla cifra meno significativa.

    Commento di maramax — febbraio 7, 2008 @ 5:26 pm

  4. Scusate il doppio post ma telperion ha modificato, perciò volevo aggiungere un pensiero:
    mi sembra che la strada di Compiz obblighi l’adozione di xcb , ma vista l’aria che tira (kwin e metacity con estensione composite e quindi nessuno che obblighi le distro al gran passo verso xcb) non sarebbe il caso di pensarci un attimo? Il progetto non rischia di morire solo e abbandonato dopo tutti gli utenti che ha trascinato al pinguino?

    Commento di maramax — febbraio 7, 2008 @ 5:30 pm

  5. Veramente:
    http://gitweb.opencompositing.org/?p=compiz;a=summary

    l’unica taggata “stable” è la 0.2.2
    le altre sono taggate (correttamente) release.

    Tanto per fare i pignoli.😀

    Commento di telperion — febbraio 7, 2008 @ 5:31 pm

  6. @maramax:
    come detto per ora la necessità di xcb è facilmente “revertibile”, in futuro vedremo.

    Commento di telperion — febbraio 7, 2008 @ 5:35 pm

  7. ma la nuova release con object framework non doveva essere il miracolo ?
    mah ….
    sempre meglio di kwin comunque =)

    Commento di astenersiperditempo — febbraio 7, 2008 @ 8:14 pm

  8. la nuova release con object framework come descritto da Reveman cambia solo le interfacce core – plugin rendendo più semplice la scrittura e manutenzione dei medesimi, ora è un casino se cambi il core devi riscrivere TUTTI i plugin.
    Infatti attualmente i plugin per 0.5.x/0.7.x non funzionano sul 0.6.x e viceversa, obbligando a mantenere 2 versioni degli stessi con 2 interfacce diverse, uguale spreco di risorse.

    Commento di telperion — febbraio 7, 2008 @ 8:27 pm


RSS feed for comments on this post.

Blog su WordPress.com.

%d blogger cliccano Mi Piace per questo: