Tecnologia e non solo

gennaio 22, 2008

Pasticcini e pasticcioni.

Filed under: Archlinux,Varie — telperion @ 4:57 pm

Se con il recente aggiornamento di ffmpeg su arch linux (e solo su arch linux),
vlc (di nuovo!) non apre più file avi con il messaggio da terminale:

main decoder error: no suitable decoder module for fourcc `XVID'.

bene siete vittime dell’ennesimo “pasticcio”.

Se ne esce fuori in maniera non proprio semplice con questa discussione del forum internazionale.
La soluzione, testata e funzionante che consiste nel ricompilare ffmpeg con l’opzione

--disable-swscaler

e poi vlc applicando questa patch,
oppure compilate un vlc-nightfly come suggerito da damir (thx).

Che 2 palle!

Condividerei i pacchetti ma sono ottimizzati per athlon-xp.

3 commenti

  1. pare sia pure con mandriva

    http://www.mandrakeitalia.org/modules/newbb/viewtopic.php?topic_id=13531&forum=5&post_id=85800

    Commento di Shadowed — gennaio 24, 2008 @ 1:02 pm

  2. @Shadowed:
    probabile l’errore avviene con XVID e DIVX

    Commento di telperion — gennaio 24, 2008 @ 4:50 pm

  3. @telperion
    volevo segnalarti che ho risolto il problema che affliggeva il funzionamento delle versioni nightly di vlc.
    In sostanza, ffmpeg occorre sempre ricompilarlo con il flag --disable-swscaler (in compenso, con le versioni vlc-nightly non è più necessario applicare la patch) ed aggiungere al PKGBUILD che si trova su AUR il flag --enable-fast-install e tutto funziona a meraviglia.
    Comunque, il problema era dovuto a libtool, oltre a quelli già noti per la versione stabile.

    Commento di damir — febbraio 1, 2008 @ 3:16 pm


RSS feed for comments on this post.

Crea un sito o un blog gratuitamente presso WordPress.com.

%d blogger cliccano Mi Piace per questo: