Tecnologia e non solo

agosto 30, 2007

Questioni de core. Tira e molla.

Filed under: Compiz-core,Fusion — telperion @ 5:28 pm

Trovata la gabola per aggirare la perfida x11-xcb con la revert patch,
che consentiva anche a noi umani di compilare l’ultimo compiz,
ecco un altro “colpo di genio” che inserisce altre dipendenze e non solo, alla perfida lib.

Risultato: non si compila più la 0.5.5.
Non si compila più la master (con xcb) e nemmeno la 0.6.0.
STRIKE!!!

Aggiornamento: la 0.6.0 dovrebbe essere a posto.

Altra patch per rimuovere tutto?
Quanto andiamo avanti cosi?

Ai “posters” l’ardua sentenza.

Per chi usa makefusion8: nuovo script aggiornamenti ON

Dunque che mancava il file object.c in src l’avevo visto anche io (bravo David!!)(aggiunto)
inoltre la patch si può spostare al nuovo compiz-core.h,
quello che non mi è troppo piaciuto è che qualcuno in questa discussione
alla richiesta di opportuni chiarimenti (chi ha gentoo non ha pacchetti
deve compliare quello che c’è al momento) si è visto rispondere:

And please, folks, we don’t need a new thread from a dozen people every time git breaks. If you see a problem with git that lasts for more than a few days, open up a bug report.

Remember: It’s development code and it’s going to break.

Adam

WOW bel modo di fare comunità.
Fate che chiuderlo il git và,
compilatevelo e testatevelo da voi,
e scusate tanto se vi secchiamo!

😦

Annunci

31 commenti

  1. sempre piu intenzionato a adottare il core 0.3.4 per default 😀

    Commento di LuNa — agosto 30, 2007 @ 6:07 pm

  2. @Luna è uno sfinimento, mi sto rompendo.

    Commento di telperion — agosto 30, 2007 @ 6:12 pm

  3. Anche la 0.6.0 è “broken”. Funziona solo la 0.5.2

    Commento di telperion — agosto 30, 2007 @ 6:13 pm

  4. confermo e sottoscrivo .. poi ce li voglio questi di ubuntu a defaultizzarlo quando non funzionerà un tubo 😀

    Commento di LuNa — agosto 30, 2007 @ 6:20 pm

  5. @telperion: dammi retta … smettila di fare lo script e fatti una femmina 😀 😀 😀 😀

    Commento di LuNa — agosto 30, 2007 @ 6:21 pm

  6. Io sono dovuto tornare a beryl …. con makefusion compiz si avvia ma le finestre non si muovono… su CCSM mi rimane deselezionata la funzione move windows , la seleziono e la ignora riavvio compiz e la ritrovo deselezionata.. bha

    grazie beryl…T_T

    Commento di Dox — agosto 30, 2007 @ 6:29 pm

  7. @Luna: LOL

    Commento di telperion — agosto 30, 2007 @ 6:33 pm

  8. […] Questioni de core. Tira e molla. […]

    Pingback di Fusion 0.5.5: ok il master branch. « Tecnologia e non solo — agosto 30, 2007 @ 6:36 pm

  9. […] Il ramo “master” (vedi legenda versioni) è a posto. E’ durato poco. […]

    Pingback di Fusion 0.5.5: ok il master branch. « Tecnologia e non solo — agosto 30, 2007 @ 6:38 pm

  10. @Luna:
    secondo te meglio una Blonde_90-60-90
    o una Dark-Brown_88-61-92 patchata blonde e seno “rewrited”?
    🙂

    Commento di telperion — agosto 30, 2007 @ 6:58 pm

  11. mmmmm
    dark brown (anche brown-skin possibilmente) 101-61-91 e seno “no-patch” 😀 eheh 😛

    Commento di LuNa — agosto 30, 2007 @ 7:09 pm

  12. tutti dicevano che beryl era incasinato, ma il nuovo compiz sta venendo gestito molto peggio.

    Commento di ilgufo — agosto 30, 2007 @ 10:13 pm

  13. Ma non ho veramente parole, vogliono far passare alla gente la voglia di usarlo?

    Commento di Cobra78 — agosto 30, 2007 @ 10:49 pm

  14. quanto casino…e tutto questo dovrebbe essere in Gutsy? o mamma

    Commento di thedok — agosto 30, 2007 @ 11:07 pm

  15. ma io non vedo dove stia il problema… ok… compiz compilato da git oggi non va…
    e che problema c’è… è in fase di sviluppo… mica si devono preoccupare che per un giorno tutta la gente che lo compila da git non riesca a compilarlo… sistemeranno a tempo debito
    la gente che vuole compiz-fusion funzionante mica è obbligata a usare l’ultima versione da git… si può sempre installare la 0.5.2 senza rompere tanto

    Commento di Fiste788 — agosto 31, 2007 @ 12:04 am

  16. @ Fiste788

    Si ok, ma già hanno fatto un master che sa dio quano verrà utilizzato visto che da quanto ho capito sta x11-xcb non è esattamente stabile, e non lo diverrà a breve, e poi?

    Comuqnue Gutsy in teoria dovrebbe usare la 0.5.2, quindi tutti questi problemi non la riguardano, a meno che non ricordi male io…

    Commento di Cobra78 — agosto 31, 2007 @ 12:10 am

  17. @Fiste788:
    per quello puoi anche usare Beryl
    o “Effetti desktop” e non rompere,
    anzi guarda ora levo anche Gnome e vado
    a linea di comando con la zshell!
    Anzi guarda tolgo anche Linux e metto Ms-Dos 6.22 che ci stà su un floppy, tanto per usare il prompt basta e avanza.
    Anzi ora cerco un pc che va a schede perforate e nastri.
    😉

    @Cobra: non è chiaro cosa usera Gutsy. Anch’io pensavo la 0.5.2 ma vedo 0.5.2+git20070829 quindi mi sembra più o meno l’ultimo con il classico “doppio strato di patch” di Ubuntu.

    Commento di telperion — agosto 31, 2007 @ 12:20 am

  18. Aspettando che riparino “il guasto” sul master si può sempre scaricare il git snapshot prima dell’ultima commit che ha incasinato tutto.

    Commento di Cap. J. T. Kirk — agosto 31, 2007 @ 12:53 am

  19. Ok, David Raveman in questo istante ha appena aggiunto src/object.c …. git di nuovo compilabile?
    Tra l’altro vi segnalo questo sito http://www.compiz-fusion.org ..speriamo lo mantengano aggiornato…

    Commento di Cap. J. T. Kirk — agosto 31, 2007 @ 1:04 am

  20. “Ai “posters” l’ardua sentenza.” <— LOL!!

    Telp… concordo con LuNa… lascia perde sti script, coltiva qualcosa di più serio, es: una o più ragazze…

    Approposito: per installare il pacchetto Blonde_90-60-90 devo fare il consueto “sudo apt-get install Blonde_90-60-90”?
    O ci vogliono altre librerie tipo “senlib2.6” “curveslib5.7” ecc…?

    E poi come si fa a farla partire? We mi raccomando… la vojo perfettamente funzionante in tutti gli angoli, altrimenti non se ne fa niente! 😀

    Commento di Piplos — agosto 31, 2007 @ 1:10 am

  21. @Piplos per quei pacchetti devi usare il comando
    sudo-7camicie
    per farla partire compili il file org.asm
    (ti serve un compilatore assembly).

    Perfettamente funzionante non esiste,
    sono piene di bug e malfunzionamenti “ciclici”
    in perenne stato alfa-beta (routine bla-bla-bla-bla)
    in più non usano la logica booleana ma una strana logica
    poco decifrabile, con conseguenti reazioni non congrue.

    LOL
    si scherza ovvio.

    Commento di telperion — agosto 31, 2007 @ 1:53 am

  22. @kirk
    bello il semaforo.
    No no si compila, anche con la nuova patch (vedi link sopra) un sacco di plugin sono “rotti” perchè non aggiornati al nuovo ABI system del core’ngrato.
    Bello sto gioco, uno rompe e tutti ad aggiustare,
    cosi non si sviluppa una beata cippa di nuovo
    solo si rimette continuamente a posto.
    Vabbè è “aggratis”

    Commento di telperion — agosto 31, 2007 @ 1:58 am

  23. Mi sembra che Raveman non sia un buon capo progetto, a meno che, la butto li, stia perseguendo, anzi adattando compiz-fusion molto più verso Suse (su indicazioni di Novell) che verso altre distribuzioni…insomma uno sviluppo di “parte”..

    Commento di Cap. J. T. Kirk — agosto 31, 2007 @ 8:54 am

  24. @ telperion: Ah… come sospettavo… ma una versione “normale” non c’è? Sono tutte buggate e instabili?

    LOL! 😀

    @ Tutti: ma fate come me… lasciatelo perdere a sto c***o di compiz… se proprio dovete avere i super effetti grafici per spaventare gli amici installatevi n’altra volta beryl e state a posto, no? è inutile tutto sto girotondo!

    P.s.: Senza offesa per nessuno, chiaramente! 😉

    Commento di Piplos — agosto 31, 2007 @ 12:03 pm

  25. @Piplos:
    premesso che ovviamente, Beryl è già installato
    e passare da uno all’altro è questione di un click,
    con il tuo ragionamento dovremmo tutti comprare i Mac,
    che notoriamente li accendi e basta, tipo tostapane,
    ma allora il divertimento dove sarebbe?

    Ormai seguire “core’n’grato” è assai più divertente e appassionante dell’intero ciclo di “Lost”.
    Irrinunciabile.

    PS senza offesa per Piplos (che notoriamente non ama i desktop OpenGL ma solo le auto “tamarre”).

    🙂

    Commento di telperion — agosto 31, 2007 @ 1:56 pm

  26. @Kirk: io credo, imprecazioni a parte 🙂 ,
    che Revemann faccia il suo lavoro di sviluppatore
    e quindi usi opzioni “avanzate” con largo anticipo.

    Lo sviluppo di Fusion dovrebbe invece lavorare
    su un core più “stabilizzato” e usabile.

    Invece come sai (vedi beta di Kde4, Oxygen ecc., tribe varie)
    l’ambiente Gnu/Linux è “smanioso”,
    ha il “fuoco al culo”
    e deve sempre avere/provare/usare la versione che ancora non è stata scritta.

    Le cose quando vengono rilasciate sono già vecchie,
    non c’è nessuna novità da scoprire,
    e a nessuno si interessano più.

    Schizofrenia?
    Ansia da prestazione?

    Boh!

    Commento di telperion — agosto 31, 2007 @ 2:05 pm

  27. beh tutto questo casino, come ho letto in qualche commento
    porta a un solo risultato: non esce un plugin nuovo da troppo tempo quando prima ne usciva uno ogni 3 giorni … sostanzialmente … tutto fermo e “rotto” (e non solo il sorgente ma anche le nostre sacre p…) per chi segue ubuntu a mio avviso non funzionerà tutto e su tutti i pc … poi con quel substrato patchoso ubuntuoso + git + contropatch + metticipurequestaforseemeglio + speraindio + wrapper non originale che consuma non si sa perchè piu cpu’, l’aggiornamento comprenderà un bello sfoltimento post-installazione ed oltre a quel “coso” che “qualcuno” ostenta come miracoloso (fin quanto jamie non fara qualcosa che non gli piace e allora lo denigrerà senza problema alcuno) di nome tracker tocchera estirpare pure il “default” a colpi di apt e forbici. Si salvi chi può, ah, per chi usa arch ci sono i pacchetti di repo non ufficiale con core 0.5.5 che va una meraviglia compresi ultimi plugin, aeroplanini e altre stupidaggini. ciuazz 🙂

    Commento di LuNa — agosto 31, 2007 @ 2:29 pm

  28. @LuNa:
    a proposito uso il da te segnalato Recoll
    al posto di Tracker con grande soddisfazione.

    Commento di telperion — agosto 31, 2007 @ 2:41 pm

  29. @ telperion: Già, viva le Subaru! 😀 E poi un altra cosa… come fai a preferire le complicazioni da “core’n’grato” a Lost?!? Ma ti sei visto Lost almeno una volta? Ti rendi conto di quello che hai appena detto??

    xDDD Scherzo! 😀

    Commento di Piplos — agosto 31, 2007 @ 9:02 pm

  30. @Piplos:
    “forse”, e sottolineo forse,
    in “core’n’grato” un senso magari c’è.
    In Lost sicuramente non c’è.
    🙂

    Commento di telperion — settembre 1, 2007 @ 2:11 am

  31. Ahahaha giusto! 😀

    Commento di Piplos — settembre 1, 2007 @ 7:39 pm


RSS feed for comments on this post.

%d blogger hanno fatto clic su Mi Piace per questo: