Tecnologia e non solo

luglio 24, 2007

Fusion: avviso ai naviganti 2

Filed under: Fusion — telperion @ 12:40 pm

warning!
Per chi usa lo script makefusion7
avviso, che con l’aggiornamento fatto ieri sera,
alcuni settaggi sono sballati (animazioni)
e con il ccsm è impossibile accedere ai setting del plugin animazioni.
Questo perchè
per l’ennesima volta sono stati cambiati
i parametri del plugin animazioni.


Per ripristinare il funzionamento dovete
con Fusion disattivato
aprire con un editor di testo
il file
~/.compizconfig/Default.ini
nota dal 2 agosto: ~/.config/compiz/compizconfig/Default.ini
o vostrisettings.ini se usate un nome diverso
e rimuovere completamente la sezione
[animation]
dopodiché vi dovete rifare tutti i settaggi delle animazioni.

file ini

Se per voi è troppo complicato
potete cancellare tutta la cartella nascosta ~/.compizconfig
nota dal 2 agosto: ~/.config/compiz/compizconfig
ma in questo caso perderete TUTTI i settaggi.

Cosa augurare all’autore di questi divertenti scherzetti?

Tanta diarrea (minimo 2 ore)
nel momento esatto che la “bionda” dei suoi sogni
ha finalmente deciso di dargliela?

Si! Assolutamente! E con molti rumori molesti.
E una puzza “sfollagente”.

Vi allego il mio settaggio di animazioni
che usa Glide 1 e 2 apertura/chisura/minimizza e dissolvenza per il focus,
rimuovete completamente dal vostro file le sezioni

[minimize]
e
[animation]

e copiate al fondo:

[minimize]
as_____plugin_enabled = false

[animation]
as_____plugin_enabled = true
s0_close_effects = 10
s0_close_durations = 200
s0_close_matches = (type=Normal)
s0_close_options =
s0_open_effects = 9
s0_open_durations = 450
s0_open_matches = (type=Normal)
s0_open_options =
s0_minimize_effects = 10
s0_minimize_durations = 720
s0_minimize_matches = (type=Normal)
s0_glide1_away_angle = -45.000000
s0_dodge_gap_ratio = 0.460000
s0_focus_effects = 2
s0_focus_matches = (type=Normal)
s0_glide1_away_position = -0.500000

Altri articoli su Fusion

8 commenti

  1. Hm… mi ero accorto di qualcosa, ma compilando dai git dovrebbe funzionare.
    Dovrebbe perché, su SuSE l’RPM di ieri, distribuito da cyberorg è incasinato da far paura (letteralmente inutilizzabile), mentre su gentoo gli ebuild xeffects compilati ieri sera (intorno alle 11 e qualcosa, comunque in un momento di calma del git) funzionano alla grande.

    Comunque se si compila da git, cvs, svn e simili un progetto “live” qualche scombussolamento di tanto in tanto è il minimo (in risposta a che, non mi ricordo se su questo blog o in altri, sparava veleno contro compiz-fusion dicendo che rispetto a beryl è ingestibile).

    Anzi è già tanto che funzioni tutto su distribuzioni diverse e si abbia solo qualche piccolo problema una due volte la settimana.

    Commento di Io — luglio 24, 2007 @ 1:30 pm

  2. @Io: Leggi l’aggiornamento e la soluzione e partecipa al rito di vendetta. LOL
    Vero che è un GIT,
    ma variare 2 volte i parametri di un plugin incasinato come animazioni in una settimana
    costringendo a rifarli tutti, ti becchi il Voodoo della diarrea minimo.

    Commento di telperion — luglio 24, 2007 @ 1:35 pm

  3. proprio per questo…beh…via col backup che avevo fatto il 16!!! e già che ci siamo backup delle configurazioni!!

    Commento di simo_magic — luglio 24, 2007 @ 8:51 pm

  4. no simo_magic il backup non serve,
    devi cancellare e rifare per forza la configurazione di animation.

    Commento di telperion — luglio 24, 2007 @ 8:59 pm

  5. Io uso un piccolo “accorgimento”.
    Prima di lanciarmi nell’aggiornamento da GIT, di compiz-fusion e compagnia cantante, do sempre un rapido sguardo a cosa è stato fatto qui http://gitweb.opencompositing.org/?o=age
    Inoltre vedo anche se vale la pena aggiornare. A volte aggiornano soltanto qualche lingua e quindi non vale la pena mettermi a ricompilare il possibile e l’impossibile. A volte aggiungono qualcosa (come ad esempio, ieri sera, il plugin shift che ho prontamente aggiunto al mio compiz-fusion).
    Insomma un’occhiata alla lista delle novità e solo se è il caso (e se sembra sicuro) un’aggiornamento.

    Commento di Io — luglio 24, 2007 @ 9:58 pm

  6. @Io: è scontato che chi sappia navigare e leggere una interfaccia gitweb sappia fare cosi. Come è scontato che sappia aggiornare anche un singolo componente senza upgradare tutto.
    Io aggiorno quasi tutti i giorni per segnalare eventuali soluzioni per chi non sa bene cosa fare in caso di problemi.

    Commento di telperion — luglio 25, 2007 @ 10:47 am

  7. io uso da un tot di giorni la soluzione definitiva: snapshot funzionante e basta😀

    Commento di LuNa — luglio 25, 2007 @ 5:09 pm

  8. @tutti: ripeto che forse non è chiaro.
    Questo NON è un problema che sarà risolto.
    Il plugin ANIMATION ora è cosi,
    quindi o cancellate i setting [animation] nel file ini
    (solo nel caso che li abbiate modificati dal default),
    o tutto il file ini, se volete che rifunzioni.

    Commento di telperion — luglio 25, 2007 @ 6:05 pm


RSS feed for comments on this post.

Blog su WordPress.com.

%d blogger cliccano Mi Piace per questo: