Tecnologia e non solo

giugno 5, 2007

Debian Lenny (testing) problemi Beryl

Filed under: Beryl,Debian,Lenny — telperion @ 3:51 pm

AGGIORNATO: scaricate il nuovo file.
15 giugno: gli aggiornamenti xorg del 15/06/2007 risolvono il problema.

Ho letto di problemi con Beryl
con i nuovi aggiornamenti di Debian Lenny (testing).

Niente paura stà arrivando gnome 2.18
ed il nuovo xorg (vedi per conoscenza questo post di Sid).

Il blocco delle finestre con Beryl attivato
è dovuto alla nuova libxrandr2 che finchè non sarà
aggiornato tutto xorg, da problemi (già visto in Feisty e Sid).

Si risolve ripristinando la precedente versione di libxrandr2
fino che l’aggiornamento non si completa.

In questo archivio i386

problemi_lenny_2.tar.gz (1.16 MB)

trovate:

libxrandr2_1.1.0.2-5_i386.deb
libxrandr-dev_2%3a1.1.0.2-5_i386.deb

xbase-clients_1%3a7.1.ds1-2_i386.deb

scompattatelo poi nella cartella, da amministratori (root/su/sudo)

sudo dpkg -i *.deb

e Beryl rifunzionerà regolarmente.

AGGIORNATO: aggiunto xbase-clients altrimenti avete dipendenze difettose.

11 commenti

  1. Se continui ti faranno santo🙂 attento che Ratzinger ti tiene d’occhio !

    Commento di imu — giugno 6, 2007 @ 12:35 am

  2. @imu: quà si lavora,
    mica si guardano “ragazze sculettanti in minigonna”.
    (Solo perchè piove, purtroppo).
    LOL

    Commento di telperion — giugno 6, 2007 @ 1:01 am

  3. telperion, se tu fossi una bella figa ti bacerei con la lingua!!! GRANDIOSO! ora beryl funzia e io sono felice come un bambino!!!! :DDD

    Commento di BlSabbatH — giugno 6, 2007 @ 1:15 am

  4. io ho eseguito il primo .deb ed è andato a buon fine

    per gli altri due però mi da questi errori:

    -PER IL SECONDO:
    (Lettura del database … 109400 file e directory attualmente installati.)
    Mi preparo a sostituire libxrandr-dev 2:1.1.0.2-5 (con …/libxrandr-dev_2%3a1.1.0.2-5_i386.deb) …
    Spacchetto il sostituto di libxrandr-dev …
    dpkg: problemi con le dipendenze impediscono la configurazione di libxrandr-dev:
    libxrandr-dev dipende da libxrandr2 (= 2:1.1.0.2-5); comunque:
    La versione di libxrandr2 presente sul sistema è 2:1.2.0-3ubuntu1.
    dpkg: errore processando libxrandr-dev (–install):
    problemi con le dipendenze – lasciato non configurato
    Sono occorsi degli errori processando:
    libxrandr-dev

    -PER IL TERZO:
    dpkg – attenzione: riporto xbase-clients dalla versione 7.2-0ubuntu11 alla 7.1.ds1-2.
    (Lettura del database … 109400 file e directory attualmente installati.)
    Mi preparo a sostituire xbase-clients 1:7.2-0ubuntu11 (con …/xbase-clients_1%3a7.1.ds1-2_i386.deb) …
    Spacchetto il sostituto di xbase-clients …
    dpkg: errore processando /home/rickyz/Desktop/problemi/xbase-clients_1%3a7.1.ds1-2_i386.deb (–install):
    tentata sovrascrittura di `/usr/share/man/man1/xprop.1.gz’, che si trova anche nel pacchetto xprop
    dpkg-deb: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
    Sono occorsi degli errori processando:
    /home/rickyz/Desktop/problemi/xbase-clients_1%3a7.1.ds1-2_i386.deb

    Commento di RickyZ — giugno 15, 2007 @ 2:46 pm

  5. @ricky ormai troppi pacchetti sono interdipendenti.
    La soluzione momentanea e fare il downgrade dei soli pacchetti
    libxrandr2_1.1.0.2-5_i386.deb
    libxrandr-dev_2%3a1.1.0.2-5_i386.deb
    Restano cosi dei pacchetti non configurati, ma Beryl funziona.
    Poi prima di fare un successivo aggiornamento da terminale:
    sudo apt-get install -f
    e poi aggiorni.
    Poi vedi se beryl / compiz vanno,
    se non vanno retrocedi le libxrandr, anche senza il -dev
    e avanti cosi finchè non si aggiorna tutto per bene.

    L’importante è retrocedere libxrandr2_1.1.0.2-5_i386.deb.

    Commento di telperion — giugno 15, 2007 @ 2:55 pm

  6. @Tutti: ho aggiornato ora sulla Lenny,
    e si sono aggiornati i pacchetti xorg (una decina o più).
    Ora rifunziona tutto regolarmente
    senza dover retrocedere la libxrandr2.

    Commento di telperion — giugno 15, 2007 @ 4:04 pm

  7. come hai fatto? non ho ben capito perchè sono ancora alle prime armi…
    aggiornare sulla Lenny cosa vuol dire?

    Commento di RickyZ — giugno 15, 2007 @ 7:53 pm

  8. @RickyZ: aggiorna, (se hai un mirror .it al massimo domani),
    arrivano tutti i pacchetti nuovi dell’Xorg che risolvono il problema.
    Lenny è il nome della Debian testing.

    Commento di telperion — giugno 15, 2007 @ 8:13 pm

  9. ahhh…

    ma….avendo Ubuntu? (mamma che niubbo che sono!)

    vabbe io il pezzo me lo faccio: è uguale?

    Ubuntu non è Debian con gnome ecc ecc?

    Commento di RickyZ — giugno 16, 2007 @ 8:07 pm

  10. Obrigado!!!!

    Commento di Micael — giugno 20, 2007 @ 3:33 pm

  11. Gnome is function ?

    i testing and noting sucess …

    Commento di Slipk — giugno 20, 2007 @ 4:47 pm


RSS feed for comments on this post.

Blog su WordPress.com.

%d blogger cliccano Mi Piace per questo: