Tecnologia e non solo

maggio 9, 2007

NNN – uN’altra guida per iNstallare i driver Nvidia (Debian Ubuntu)

Filed under: Attrezzi,Beryl,Dapper,Debian,Edgy,Etch,Feisty,Guida pericolosa,Gutsy — telperion @ 6:48 pm

Ultimo aggiornamento: 1 ottobre 2009

Questo è il “sunto scremato” di vari documenti
concentrati per praticità, per installare i driver
Nvidia che si scaricano dal sito www.nvidia.com.
Adatto a Debian e Ubuntu.

driver nvidia ubuntu debian

Si presume che si utilizzi sudo.
Se non usate sudo, dovete avere i privilegi di root
quando eseguite i comandi ed omettete la parola sudo
all’inizio del comando.

Si presume che si utilizzi Gnome
quindi l’editor di testo grafico nei comandi è gedit.
Se usate kde sostituite con kate.

Si presume che il driver da installare sia
NVIDIA-Linux-x86-1.0-9755-pkg1.run
se diverso adattate il nome nei comandi.

1) scaricare il file dal sito Nvidia
e salvarlo nella vostra home

http://www.nvidia.com/object/unix.html (ultima release)

http://www.nvidia.com/Download/Find.aspx?lang=en-us (ricerca tutti anche beta)

forum (discussioni e ultimissimi beta)

Elenco schede supportate

Driver legacy (1.0-7186 – 1.0-9643) schede supportate:
http://www.nvidia.com/object/IO_32667.html

Ultimi driver – schede supportate:
http://www.nvidia.com/object/IO_18897.html
Manuali tecnici.

ATTENZIONE:

dalla versione 177.13 e successive i driver Nvidia Linux supportano solo le GeForce serie 6 e successive.
Le GeForce FX (serie 5) sono supportate dai driver 173.14.xx , le schede precedenti dalle 2 versioni dei driver legacy 96.43.xx 71.86.xx come da link sopra.

Comunicato ufficiale.

2) installare programmi e librerie di supporto
(solo la prima volta) (è un’unica linea)

sudo apt-get install binutils build-essential linux-headers-$(uname -r) pkg-config xserver-xorg-dev

3) Disinstallare i driver Nvidia glx se li avetate installati da qualche deposito

sudo apt-get --purge remove nvidia-glx-new nvidia-glx nvidia-settings nvidia-glx-legacy

* nelle ultime versioni i pacchetti si chiamano nvidia-glx-NNN o anche nvidia-glx-legacy-NNN e potrebbero cambiare nel tempo, conviene usare il gestore di pacchetti, ad esempio synaptic e cercare la stringa nvidia- per trovare i pacchetti da rimuovere.

——————————————————————————
* inizio parte non più necessaria in karmic 9.10

4) In Ubuntu, se utilizzate il pacchetto linux-restricted-modules con i driver per altre
periferiche come schede wireless ecc. il pacchetto contiene uno o più driver
che vanno in conflitto con il driver che installeremo.
Non rimuovete il pacchetto (pena la perdita degli altri driver) ma

sudo gedit /etc/default/linux-restricted-modules-common

aggiungete nella riga DISABLED_MODULES=””

DISABLED_MODULES="nv nvidia_new"

Questo impedirà il caricamento del modulo fornito dal pacchetto deb.
In caso di avvii di emergenza usate il driver vesa non essendo nv
più disponibile.

In più su Ubuntu/Debian se esiste bisogna sempre cancellare il file:

sudo rm -f /lib/linux-restricted-modules/.nvidia_new_installed

file che viene installato ma non rimosso dal pacchetto
nvidia-glx-new, e che se non cancellato non farà caricare il driver al riavvio,
costringendovi a ricompilare il driver ad ogni riavvio.

(praticamente tutto il punto 4 è obbligatorio su Gutsy Gibbon e successive se non volete impazzire data l’invadenza estrema del restricted-manager (in Ubuntu 8.04 Hardy si chiama jockey-gtk jockey-kde).
Se rimuovete il gestore driver con restrizioni, il driver non si installa più.
L’unico modo per ripristinare è è reinstallare restricted modules e manager
attivare il restricted nvidia
poi disinstallare nvidia-glx
e mettere in disabled come sopra e poi installare da .run.
Insomma restricted-manager sembra creare più problemi di quanti ne risolva).

NOTA: su Ubuntu Gutsy e successive è anche attivo BulletProof-X failsafe mode,
che interferisce in caso di problemi creandone ulteriori. Consiglio di disabilitarlo con:

sudo gedit /etc/gdm/gdm.conf

trovate la riga:

FailsafeXServer=/etc/gdm/failsafeXServer

e cambiatela in

# FailsafeXServer=/etc/gdm/failsafeXServer

Ora per compilare il driver dobbiamo spegnere il server X,
stampate le istruzioni poichè bisognerà lavorare solo al terminale.

(riferimenti dal forum nvidia per i punti 2 3 e 4)

* fine non più necessario in karmic 9.10
——————————————————————————

5) premete i tasti CTRL+ALT+F1 e andate al terminale virtuale tty1
immettete user e password
poi digitate se avete gnome

sudo /etc/init.d/gdm stop

o digitate se avete kde

sudo /etc/init.d/kdm stop

*in ubuntu 9.10 il comando diventa:
sudo stop gdm

Andate nella cartella dove avete salvato il file .run

cd /home/vostronomeutente

e lanciate il comando

sudo sh NVIDIA-Linux-x86-1.0-9755-pkg1.run -a -n -N

Per Debian Sid con xorg 1.3.0 il comando deve essere: (*)

sudo sh NVIDIA-Linux-x86-1.0-9755-pkg1.run -a -n -N --x-module-path=/usr/lib/xorg/modules

(Con i driver => 100.14.09 non è più necessario specificare x-module-path)

Nota per Debian Sid con kernel 2.6.20 o superiore è necessario ricompilare il kernel
con la voce paravirtualization in ‘processor features’ disabilitata.
Aggiornamento: dalla versione 2.6.22 del kernel Debian non è più necessario disabilitare paravirtualization.

Al termine del processo l’installer ci chiederà
se deve modificare il file xorg.conf per abilitare il driver
rispondete si solo la prima volta che installate il driver
le volte successive non sarà più necessario.

Volendo potete anche fare a mano la stessa operazione di configurazione:
(fonte)

sudo nano -w /etc/X11/xorg.conf

nella sezione Module eliminate le linee
Load "dri"
Load "GLCore"
e aggiungete se non c’è
Load "glx"

Poi in una sezione Device
Rimuovete la linea:
Driver "nv"
(o Driver "vesa")
(o Driver "fbdev")
e sostuitela con
Driver "nvidia"

6) Possiamo ora far ripartire il server X

gnome:
sudo /etc/init.d/gdm restart

*in ubuntu 9.10 il comando diventa:
sudo start gdm

o (kde):
sudo /etc/init.d/kdm restart

Conservate il file NVIDIA*.run e
ricordate che ad ogni aggiornamento kernel o xorg-xserver-core o libgl1-mesa-glx
dovrete ricompilare il driver con la stessa procedura,
a partire dal punto 5 senza modificare il file di configurazione
xorg.conf

nvidia driver ubuntu debian

Aiglx – Beryl Compiz Addendum

Per attivare le funzionalità di composing
occorre inserire alcuni parametri nel file xorg.conf

nella sezione screen
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"
e verificare che DefaultDepth sia 24
DefaultDepth 24

Bisogna poi aggiungere al fondo la sezione
Section "Extensions"
Option "Composite" "Enable"
EndSection

Potete editare a mano il file oppure eseguire il comando (è un’unica linea):

sudo nvidia-xconfig --composite --render-accel --allow-glx-with-composite --add-argb-glx-visuals --depth=24

che esegue queste operazioni per voi

Tutte le opzioni del comando nvidia-xconfig:
nvidia-xconfig -A

Lista completa di tutte le opzioni

http://us.download.nvidia.com/XFree86/Linux-x86/180.22/README/appendix-b.html

Turbo cache – memoria condivisa
Se avete schede con memoria condivisa è bene specificare
il valore reale della memoria video della scheda in KB (1MB=1024KB)
Esempio per una scheda con 32MB aggiungete la riga (32*1024=32768)
VideoRam 32768

esempio:
Section "Device"
Identifier "nVidia Corporation G71 [GeForce 7300 GS]"
Driver "nvidia"
VideoRam 32768
EndSection

Aggiornamento: i driver 100.14.19 sembra abbiano risolto i problemi di gestione
della memoria video condivisa, per cui non dovreste più avere problemi di
finestre nere all’esaurimento della ram video.

Appendice.

Problema: non prende la configurazione del monitor impostata
nell’xorg.conf (risoluzione – refresh)

Aggiungere nella sezione device:
Option "UseEDID" "FALSE"
o da terminale
sudo nvidia-xconfig --no-use-edid

Per rendere effettive le variazioni al file xorg.conf
è necessario riavviare il server x.

Che versione di Gnu/Linux state usando?
lsb_release -a

Che versione di Xorg state usando?
Xorg -version

Che scheda video avete?
lspci | grep "VGA"

Che versione di driver Nvidia state usando?
cat /proc/driver/nvidia/version

Come rimuovere questo driver?
sudo sh NVIDIA-Linux-x86-1.0-9755-pkg1.run --uninstall

Dopo l’aggiornamento del pacchetto xserver-xorg-core ho problemi/torna al login
Reinstallate dal punto 5 o leggete questa guida di Imu

Dopo l’aggiornamento del pacchetto libgl1-mesa-glx ho problemi/torna al login
Reinstallate dal punto 5 o leggete questa guida di Imu

Ogni volta che un aggiornamento mi “rompe” il driver e devo ricompilarlo,
posso fare uno script che mi esegua il punto 5 quasi automaticamente?

Certo, i computer sono fatti apposta per automatizzare le cose.
Allora nella home create una cartella nvidia e copiateci il file .run con il driver.
Poi da un terminale:

gedit ~/reinstalla-nvidia.sh

e copiateci dentro

sudo /etc/init.d/gdm stop
cd ~/nvidia
sudo sh NVIDIA-Linux-x86-1.0-9755-pkg1.run -a -n -N
sudo /etc/init.d/gdm restart

per ubuntu 9.10

sudo stop gdm
cd ~/nvidia
sudo sh NVIDIA-Linux-x86-1.0-9755-pkg1.run -a -n -N
sudo start gdm

Se avete kde sostituite i 2 gdm con kdm, salvate il file.

Ora per reinstallare i driver,
oppure se non si avvia il server X
(rispondete NO alla schermata che vi chiede se volete vedere il log)
sarà sufficiente premete i tasti
CTRL+ALT+F1 e andate al terminale virtuale tty1
immettete user e password. poi semplicemente digitate

sh reinstalla-nvidia.sh

vi verrà richiesta la password di sudo e tutto verrà eseguito automaticamente.
Ad eventuali domande tipo esiste già un driver sostituisco rispondete SI
mentre alla richiesta finale di modifica del file xorg.conf rispondete sempre NO.
Al termine verrà automaticamente riavviata la grafica con il nuovo driver.

Posso compilare solo modulo per altri/nuovi kernel?

Se avete già installato il driver, potete creare anche soltanto
il modulo per altri kernel con il comando:

sudo sh NVIDIA-Linux-x86-100.14.09-pkg1.run -K --kernel-name=2.6.20-16-generic

altro esempio:

sudo sh NVIDIA-Linux-x86-100.14.09-pkg1.run -K --kernel-name=2.6.21.5-mc1

Potete eseguirlo da terminale dentro xorg senza uscire dalla sessione grafica.

-K compila solo il modulo e
–kernel-name=NOMEKERNEL per quale kernel deve compilarlo.
Tutte le opzioni:

sh NVIDIA-Linux-x86-100.14.09-pkg1.run -A

Settare xorg.conf con nvidia-settings.

Da terminale:

sudo nvidia-settings

immagine nvidia-settings

Cliccare su X server Display configuration
poi detect display, poi il tasto Advanced (che diventa basic)
poi regolate risoluzione frequenza (gli LCD sono 60Hz di solito)
apply per provare, quando è tutto a posto
save to x configuation file -> merge existing file.

Potete settare anche, se li avete, il doppio monitor e l’uscita tv

Attenzione: causa un bug con le lingue di nvidia-settings 173.14.05
potreste avere l’errore lanciando nvidia-setings:

Unable to load X Server Display Configuration page:
Failed to parse the following modeline of display device

Da terminale lanciate:

LANG=C sudo nvidia-settings

e con la lingua inglese nvidia-settings funzionerà tranquillamente.
Altre informazioni qui.
Questo bug è stato risolto nella versione 173.14.09 che funziona regolarmente

Ubuntu 8.04 Hardy Heron e schermo bloccato a 800×600 o meno

La risoluzione è cosi bassa che non riesco ad utilizzare nvidia-settings.
Seguite queste indicazioni e poi utilizzate sudo nvidia-settings, per configurare alla perfezione.

Ubuntu 9.04 e schermo bloccato a 800×600 o meno

Seguite questo post e provate ad usare lo xorg.conf generico proposto.

kernel rt (bassa latenza)
Ufficialmente i driver Nvidia non supportano i kernel rt.
In questa discussione www.nvnews.net/vbulletin/showthread.php?t=115884 trovate alla risposta #4 una patch

If you want to use 173.14.xx and other recent drivers with current Linux/-rt* kernels, you can try the attached patch (at your own risk). With the patch applied, the driver worked fine in the limited testing I did.

da applicare a driver 173.14.xx o superiori, alla risposta #7 come applicarla al file .run

Driver 173.14.12 (per la serie FX 5***) e kernel 2.6.27
Dovete applicare una patch per compilare questi driver con il kernel 2.6.27

mkdir nvidia
cd nvidia
wget http://download.nvidia.com/XFree86/Linux-x86/173.14.12/NVIDIA-Linux-x86-173.14.12-pkg1.run
wget http://kanotix.com/files/173.14.12/NVIDIA_173.14.12_2.6.27.patch
sh ./NVIDIA-Linux-x86-173.14.12-pkg1.run --extract-only
mv NVIDIA-Linux-x86-173.14.12-pkg1 NVIDIA-Linux-x86-173.14.12-pkg0
patch -p0 < NVIDIA_173.14.12_2.6.27.patch
cd NVIDIA-Linux-x86-173.14.12-pkg0
./nvidia-installer

fonti:
www.nvnews.net/vbulletin
opensource2007.netsons.org

No so che scheda Nvidia ho e che driver installare

installate hwinfo
sudo apt-get install hwinfo
in un terminale ottenete l’id della scheda
hwinfo --gfxcard | grep Device:
Device: pci 0x0401
cercate 0x0401 nella lista Nvidia
e saprete che scheda avete e che driver usare.

Nvidia: tv-out analogico.
Nvidia: tv-out analogico.

Gdm non parte – (EE) no devices detected.
In casi particolari o in presenza di SLI le schede non vengono rilevate.
Inserite nello xorg.conf nella sezione device della scheda video prima della riga
Driver "nvidia"
la riga
Busid "PCI:numero:0:0"
dove numero è il primo senza zero ricavato dal comando

lspci | grep VGA

esempio
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600GT (rev a1)
Busid "PCI:1:0:0"

in caso di SLI prendete quello della prima scheda
03:00.0 VGA compatible controller: nVidia Corporation GeForce 9600 GSO (rev a2)
05:00.0 VGA compatible controller: nVidia Corporation GeForce 9600 GSO (rev a2)
Busid "PCI:3:0:0"

Section "Device"
	Identifier	"Configured Video Device"
        Busid "PCI:3:0:0"
	Driver	"nvidia"
EndSection

Un ringraziamento a Imu anche per le citate soluzioni su Debian Sid nel punto 5, e a LuNa per la procedura di apllicazione della patch per le FX e a tseliot per la patch.

🙂

Annunci

210 commenti

  1. Io uso Envy… e sono contento 😀
    Perchè complicarsi la vita?

    p.s. bel blog… grazie al te ora Beryl gira sul mio System

    Ciaoz, KvR

    Commento di KvR — maggio 9, 2007 @ 10:21 pm

  2. Grazie a te per i complimenti , ma non ho fatto nulla di straordinario, belle schede le Nvidia BFG :>

    Commento di imu — maggio 9, 2007 @ 10:24 pm

  3. @KvR
    Ti rispondo modificando uno slogan della Pubblicità:
    Sentirsi Dio sul proprio pc GNU/Linux non ha prezzo …per tutto il resto c’è Mastercard !

    Commento di imu — maggio 9, 2007 @ 10:38 pm

  4. Se avete Ati
    e volete una buona guida per compilare ed installare i driver fglrx
    vi consiglio questa.

    Commento di telperion — maggio 12, 2007 @ 5:48 pm

  5. Mi hai fatto venire un dubbio Telperion, lo sapevo che non dovevo leggere la tua guida 😉
    Il fatto che il mio Xorg per abilitare al AiGLX abbia questi paramtri (è da un bel po’ che non seguo le vicissitudini in casa AiGLX & Beryl) è sbagliato visto che c’è una sola voce di quelle da te indicate?

    […]
    Section “Screen”
    # Enable 32-bit ARGB GLX Visuals
    # If you are using an older version of compiz that
    # does not support rendering into the Composite
    # Overlay Window, you will need to disable clipping
    # of GLX rendering to the X Root window with this
    # option, or you will get a blank screen after
    # starting compiz:
    Option “AddARGBGLXVisuals” “True”
    Option “DisableGLXRootClipping” “True”
    Option “TripleBuffer” “true”
    Identifier “Default Screen”
    DefaultDepth 24

    […]

    Section “DRI”
    Mode 0666

    Commento di NevidS — maggio 13, 2007 @ 8:12 pm

  6. @NevidS: Option “AddARGBGLXVisuals” “True” è la più importante le altre sono opzionali e nel link Lista completa di tutte le opzioni, puoi verificare una ad una a cosa corrispondono.
    La Section DRI la puoi tranquillamente eliminare.

    Commento di telperion — maggio 13, 2007 @ 11:35 pm

  7. Aggiunto un esempio di script per automatizzare la ricompilazione del driver.

    Commento di telperion — maggio 14, 2007 @ 7:15 pm

  8. ò telperion: puoi vedere se il mio post precedente è stato eliminato o qualcosa? ciao

    Commento di TequilaMex — maggio 17, 2007 @ 12:29 am

  9. @TequilaMex: non c’è nulla.

    Commento di telperion — maggio 17, 2007 @ 4:20 pm

  10. Quando do il comando sudo sh NVIDIA -linux ecc. mi da errore e’ non si installa na mazza per i passaggi precedenti invece tutto bene.
    Nessuno ha mai avuto questo problema ?

    Commento di massi — maggio 30, 2007 @ 7:13 pm

  11. @massi: NVIDIA-Linux-x86-1.0-9755-pkg1.run tutto attaccato
    è il nome del file, inizia a scrivere NVIDIA
    poi premi TAB e lo completa automaticamente.
    (Meglio che studi un po il terminale però prima di avventurarti in stè cose).

    Commento di telperion — maggio 30, 2007 @ 8:18 pm

  12. Aggiornamento 100.14.09

    Commento di telperion — giugno 9, 2007 @ 1:57 pm

  13. Aggiornato: compilazione solo modulo per altri kernel

    Commento di telperion — giugno 18, 2007 @ 1:27 am

  14. praticamente neofita e ignorante arrivo al punto 5 della guida e la pressione dei tasti CTRL+ALT+F1 non dà alcun risultato, nessun terminale virtuale tty1 e impossibilità di spegnere il server X. Grazie.

    Commento di matteo — luglio 29, 2007 @ 9:29 am

  15. @matteo premi i 3 tasti contemporaneamente, impossibile non funzionino, ctrl+alt+ da f1 a f6 consolle virtuali (una vale l’altra) ctrl+alt+f7 console grafica. i ctrl alt a sinistra della tastiera.

    Commento di telperion — luglio 29, 2007 @ 10:53 am

  16. …è vero, non era attivato il tasto F bloc della tastiera, mi scuso.

    Commento di matteo — luglio 29, 2007 @ 11:09 am

  17. …fatto ma non riesce ad aprire il file .run nè da consolle tty1 nè da consolle grafica, questo il messaggio:
    Impossibile aprire il file «/home/matteo/NVIDIA-Linux-x86-1.0-9755-pkg1.run».
    gedit non è stato in grado di determinare la codifica dei caratteri.
    Assicurarsi che il file non sia un file binario.
    Selezionare una codifica dei caratteri dal menù e riprovare.
    Le codifiche che ho provato sono locale attuale UTF-8 e occidentale iso 8859-15

    Commento di matteo — luglio 29, 2007 @ 11:57 am

  18. ciao
    @matteo
    credo il problema sia questo:
    «/home/matteo/NVIDIA-Linux-x86-1.0-9755-pkg1.run»
    devi solo entrare nella tua home:
    cd /home/nome utente
    poi dai il comando di installazione
    sudo sh NVIDIA-Linux-x86-1.0-9755-pkg1.run -a -n -N

    Commento di deer — luglio 29, 2007 @ 12:33 pm

  19. @matteo: forse prima di cimentarti con guide più o meno complesse sarebbe bene imparassi un pò ad usare il terminale ed i suoi comandi
    come esempio ls che ti fa vedere che file ci sono nella cartella dove sei posizionato
    e TAB che completa il nome del file, esempio NV + TAB ti completa il nome del driver NV*.run automaticamente.
    Per gli inesperti con adept/synaptic trovate i pacchetti deb dei driver già belli e pronti.

    Commento di telperion — luglio 29, 2007 @ 1:16 pm

  20. grazie, certamente è così. Infatti avevo già provveduto ad installare il pacchetto nvidia-glx-dev con synaptic ma speravo di aver più fortuna con il file .run tuttavia il risultato è lo stesso, una volta installato il driver la modalità grafica non funziona più.

    Commento di matteo — luglio 30, 2007 @ 4:44 pm

  21. dopo 2 day di smanettamenti ci voleva la tua guida per farmi funzionare il tutto alla perfezione grazie mille.
    Guida ottima e sopratutto chiara! 😀

    Commento di pizzetta67 — agosto 16, 2007 @ 5:46 pm

  22. @pizzetta67: grazie 🙂

    Commento di telperion — agosto 16, 2007 @ 6:25 pm

  23. sono nuovissimo di linux e vorrei installare i driver video della 8600gt ma mi da questo errore quando apro il file che ho scaricato«/home/matteo/NVIDIA-Linux-x86-1.0-9755-pkg1.run»come posso fare???

    Commento di massimo — agosto 23, 2007 @ 3:23 pm

  24. @massimo:
    se sei nuovissimo meglio che usi synaptic o adept o apt e installi il pacchetto nvidia-new.
    Questa è una guida “per esperti” che hanno kernel custom
    o a cui non piacciono troppo i pacchetti per vari motivi.
    🙂

    Commento di telperion — agosto 23, 2007 @ 6:18 pm

  25. grazie, dopo 2 giorni ora funziona la scheda video… ora cerchero’ di far funzionare l’audio e poi la wireless. Ho un dv6500 …

    Commento di Marco Palombi — agosto 31, 2007 @ 6:58 pm

  26. […] Altre info sui driver Nvidia nella “guida pericolosa”. […]

    Pingback di Xorg 7.3 Nvidia DRI « Tecnologia e non solo — settembre 23, 2007 @ 8:36 pm

  27. Io ho dovuto anche rimuovere il pacchetto linux-restricted-modules-2.6.20-16-generic
    Che dici?
    http://forum.ubuntu-it.org/index.php?topic=120623.msg798661#msg798661

    Commento di Mistermax80 — ottobre 2, 2007 @ 2:59 pm

  28. @Mistermax80:
    se non ti servono driver per altre periferiche contenuti nei
    linux-restricted-modules puoi rimuoverlo senza problemi,
    altrimenti se lo tieni basta aggiungere
    DISABLED_MODULES=”nv nvidia_new”
    come descrito nel punto 4 e tutto funziona.

    Commento di telperion — ottobre 2, 2007 @ 3:33 pm

  29. Quello che è capitato a me e ad altre persone è che quando poi si è riusciti a far funzionare i driver, sono andato a toccare il restriced-manager… anche togliendo la spunta… e questo mi ha creato casini…sicuramente non andava toccato…

    Commento di Mistermax80 — ottobre 2, 2007 @ 5:03 pm

  30. […] Avevo il driver gia installato quindi è stato sufficiente compilare solo il modulo per il nuovo kernel con il metodo “Posso compilare solo modulo per altri/nuovi kernel?” della guida NNN – uN’altra guida per iNstallare i driver Nvidia (Debian Ubuntu) […]

    Pingback di Il gibbone alla vaniglia. « Tecnologia e non solo — ottobre 13, 2007 @ 8:28 pm

  31. Dopo aver installato tutto alla perfezione mi da qualche errore al riavvio. Mi riparte in vesa generic driver, poi se riprovo ad installare il driver nvidia scaricato dal sito me lo installa, avvio gdm e tutto parte alla perfezione. Non riesco a capire da che cosa può dipendere…un’altro problema che ho riscontrato con compiz è il fatto che abilitando un pò di effetti la barra delle finestre non si visualizza.. come se avesse qualche problema di rendering.. mah.. qualcuno sa cosa può essere?

    Commento di PerZoo — ottobre 21, 2007 @ 1:30 am

  32. @PerZoo:
    hai fatto
    sudo gedit /etc/default/linux-restricted-modules-common
    aggiungete alla riga DISABLED_MODULES:
    DISABLED_MODULES="nv nvidia_new"
    altrimenti ad ogni riavvio carica il modulo del kernel sbagliato.
    (Su gutsy bisogna lasciare intallati i restricted modules
    e disabilitarli così, OBBLIGATORIO)

    Commento di telperion — ottobre 21, 2007 @ 11:40 am

  33. Ciao!!
    Ho un dell latitude d830 con nvidia quadro 135, e i driver di ubuntu non sembrano supportare l’accellerazione hw o più probabilmente io non sono capace di configurarla ma sono dettagli 🙂
    Seguendo la guida rieco ad abilitare accellerazione e va che è uno splendore, ma ho un problema:
    se dopo aver installato il driver proprietario (infatti appare il logo), volessi abilitare gli effetti desktop, come faccio?
    Io ho provato con clik dx sulla scrivania, imposta sfondo, effetti visivi ma poi mi chiede: “abilitare il driver” e se gli dico si lui attiva quelli di ubuntu…
    Come faccio??
    Grazie,
    Nicola

    Commento di nicola — ottobre 26, 2007 @ 9:20 am

  34. @Nicola
    è un problema specifico di “effetti visivi” di Ubuntu,
    non c’entra il driver sono gli automatismi
    che se non usi il pacchetto ufficiale fanno casini.

    L’unica è installare anche il pacchetto del setting manager e lanciare il tutto a mano
    oppure con l’applicazione compiz-fusion-icon.
    Se hai dubbi cerca/chiedi sul forum ubuntu.it.

    Commento di telperion — ottobre 26, 2007 @ 6:10 pm

  35. a me Envy non funziona, ma solo questa guida presa da Ubuntu
    Da terminale:

    TELEPERION, hai una guida per settare Compiz Fusion ?

    Commento di Cannibal Corpse - Necropedophile — ottobre 28, 2007 @ 5:05 pm

  36. Chi l’ha detto che il codice non funziona ?
    E’ preso dal sito di Ubuntu e funziona benissimo

    Commento di Cannibal Corpse - I cum Blood — ottobre 28, 2007 @ 11:28 pm

  37. Grazie mille per la risposta, mi avete risolto il “dubbio” per cui pensavo fosse colpa dei miei procedimenti..

    Commento di nicola — ottobre 29, 2007 @ 9:20 am

  38. @Nicola
    puoi lasciarli anzi come detto installa anche il pacchetto ccsm (setting manager) e se lo trovi compiz-fusion-icon e poi fai patire compiz con compiz-fusion-icon oppure con uno script,
    è solo lo stupido meccanismo di lancio di “effetti visivi” che toppa, il compiz di Ubuntu funziona, non devi togliere nulla.

    Commento di telperion — ottobre 29, 2007 @ 10:40 am

  39. @Nicola e @Tutti
    questa è una guida per intallare i driver Nvidia
    non per installare compiz/fusion.
    @Nicola:
    Non devi installare xgl-server, devi fare come ho detto sopra.
    Rimuovo per off-topic.
    Vai sul forum di Ubuntu e chiedi li, ci sono 100 topic sull’argomento.

    Commento di telperion — ottobre 29, 2007 @ 7:07 pm

  40. Perfettamente daccordo. Scusate.
    Comunque compilmenti per la guida!
    Ciao
    -nicola

    Commento di nicola — ottobre 30, 2007 @ 9:40 am

  41. OPERAZIONE RIUSCITA, però ho un problema

    1 volta su 2 quando accendo il PC, carica ubuntu ma alla schermata di login il monitor diventa tutto nero e compare la scritta “FUORI PORTATA”

    Devo schiacciare RESET

    Ho un ASUS PW201 , cioè un 20″ 1680×1050. Sul manuale non c’è scritto le frequenze di refresh

    COSA PUò ESSERE ?

    Commento di Cannibal Corpse - I cum Blood — ottobre 31, 2007 @ 1:56 am

  42. Cannibal fai

    sudo nvidia-settings
    vai su display configuration e metti una frequenza
    di 60 hz fai APPLY se tutto funziona
    premi save to x configuration file e accetta quanto proposto.
    Se non risolve no so che dirti.

    Commento di telperion — ottobre 31, 2007 @ 5:17 pm

  43. Ciao ho seguito la tua guida (molto chiara tra l’altro) e ho installato i driver, solo quando vado a dare il comando

    glxinfo|grep render

    mi risponde:

    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    OpenGL renderer string: GeForce 7300 SE/7200 GS/PCI/SSE2

    ho già disattivato i driver nv nvidia_new nei restricted modules..
    sapresti consigliarmi?

    dimenticavo ho installato i driver 100.14.11 (prima avevo provato 100.14.23 ma avevo lo stesso problema e così ho provato a cambiarli)

    grazie mille per qualsiasi consiglio

    Commento di Caronte — novembre 9, 2007 @ 1:31 am

  44. @caronte
    hai mica xserver-xgl installato?
    Se si, rimuovilo
    sudo dpkg -r xserver-xgl
    e riavvia.

    Commento di telperion — novembre 9, 2007 @ 12:39 pm

  45. non saprei…stasera appena arrivo a casa provo poi ti dico.
    Intanto grazie mille

    Commento di Caronte — novembre 9, 2007 @ 1:54 pm

  46. fatto era proprio quello il problema! grazie mille ancora e complimenti per la guida, chiara e di facile comprensione!
    ora posso lanciarmi col provare compiz 😉

    Commento di Caronte — novembre 9, 2007 @ 6:18 pm

  47. Ma la procedura di installazione per chi non ha installato i restricted modules qual è ?

    Io ho provato a rifare la procedura appena installato ubuntu e non funziona, mentre se installo il driver di ubuntu (restricted modules) e poi seguo la procedura funziona…..

    Dead Skin Mask

    Commento di Cannibal Corpse - Post Mortem Ejaculation — novembre 11, 2007 @ 6:48 pm

  48. @Cannibal
    con Gusty devi per forza installare i restricted (come indicato)
    altrimenti non ti compila il modulo, per via delle impostazioni
    degli script di Ubuntu.
    Vedi:

    (praticamente tutto il punto 4 è obbligatorio su Gutsy Gibbon …

    e sempre cancellare il file
    sudo rm -f /lib/linux-restricted-modules/.nvidia_new_installed

    Commento di telperion — novembre 11, 2007 @ 7:01 pm

  49. Scusa il disturbo ma volevo chiederti una cosa. Devo installare i driver versione 73.xx, ma l’installer non riesce compilare il modulo del kernel e l’installazione si blocca.

    Come posso fare?

    Grazie, ciao

    Commento di Paolo — novembre 23, 2007 @ 1:17 pm

  50. @Paolo:

    Linux IA32
    Latest Version: 100.14.19
    Latest Legacy GPU version (1.0-71xx series): 71.86.01
    Latest Legacy GPU version (1.0-96xx series): 96.43.01

    I driver 73.xx non so se sono supportati con gli ultimi xorg.
    Al limite posta il messaggio di errore e che distribuzione usi.

    Commento di telperion — novembre 23, 2007 @ 1:50 pm

  51. @ telperion:
    grazie per la guida, una domanda: se do ctrl+alt+F1(o F2 etc) invece che la console virtuale mi viene un bello schermo tutto nero, anche con l’opzione vga=791 in grub, dove è finito tty ?
    abbi pazienza, grazie
    saluti

    Commento di ricochet — novembre 26, 2007 @ 11:22 am

  52. @ricochet:
    non ho idea, se stai compilando un driver beta prova con il NVIDIA-Linux-x86-100.14.19-pkg1.run, se stai usando quello allora prova con il beta NVIDIA-Linux-x86-169.04-pkg1.run
    altro non mi viene in mente.

    Commento di telperion — novembre 26, 2007 @ 5:13 pm

  53. @ telperion:
    mi sa che ho fatto qualche mastrusso con lo gnomo, se parto in recovery mode mi viene la console ma quando faccio partire gdm mi da un errore di hal, se metto la live appena parte mi da :
    There was an error starting the GNOME Settings Daemon.

    Some things, such as themes, sounds, or background settings may not work correctly.

    The last error message was:

    Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

    GNOME will still try to restart the Settings Daemon next time you log in.
    cosa che non mi aveva mai fatto…
    “Rimetto” i drive di Ubuntu e provo a ricominciare da capo! 🙂
    grazie, saluti

    Commento di ricochet — novembre 28, 2007 @ 8:32 pm

  54. @ricochet hal e tutto il resto hanno poco a che fare col driver.
    Se il driver non và il massimo che capita è che non parte il gdm e resti col terminale.
    Metti “vesa” nello xorg.conf e vedi se funziona gnome (punto 5).

    Commento di telperion — novembre 28, 2007 @ 9:02 pm

  55. @ telperion:
    sì HAL non va perchè giro perenne in acpi=off (il mio pentium4 1.6 Gh nunieafa’) ma il problema con la live non l’avevo mai avuto 😐
    per quanto riguarda i driver sì in vesa gia’ ci sono; anche perche’ se faccio partire i restricted-modules
    mi dice “non in uso”….e se li abilito al riavvio mi parte in emergenza a 800×600…..
    mi sono accorto che non riesce a disinstallare nvidia-glx-new perchè:

    “Rimuovo nvidia-glx-new …
    dpkg-divert: il cambio del nome comporta la sovrascrittura di `/usr/lib/libGL.so.1.2′ con
    un file diverso `/usr/lib/nvidia/libGL.so.1.2.xlibmesa’, che non è consentito
    dpkg: errore processando nvidia-glx-new (–remove):
    il sottoprocesso post-removal script ha restituito un codice di errore 2
    Sono occorsi degli errori processando:
    nvidia-glx-new
    E: Sub-process /usr/bin/dpkg returned an error code (1)”

    Il fatto è che ho compilato il kernel 2.6.23.8 e dopo aver fatto partire il .run mi ha dato un errore perchè il test per la shared memory era fallito e di controllare nel kernel l’opzione CONFIG_SYSVPC, che naturalmente era “=is not set”…….da lì è cominciato il remescio, tra cui ricompilazione, (era anche la prima volta che provavo a mettere i driver nvidia ufficiali :o) e credo di aver ingozzato di .run il sistema, senzasenso, 😦 d’altronde sbagliando s’impara,anche se nessuno dice quante nvolte !?
    grazie anche solo di esser arrivato fin quaggiu’ 😉
    saluti

    Commento di ricochet — novembre 29, 2007 @ 10:27 pm

  56. dpkg-divert?
    E che c’entra con i driver installati con questa guida?
    Non ho idea che cosa tu abbia fatto.
    Tutta l’operazione è relativamente semplice.
    Se compili un nuovo kernel ti conviene avviare con l’ultimo disponibile della distro
    e fare un sudo make oldconfig e poi un sudo make menuconfig per ottimizzare CPU e memoria,
    senza andare a ravanare nei moduli che ti porta solo a grandi casini, come consigliato
    in https://telperion.wordpress.com/2007/07/10/estate-kernel-alla-vaniglia/
    poi vedi tu.

    Commento di telperion — novembre 30, 2007 @ 12:00 am

  57. @ telperion:
    OK, messaggio ricevuto
    ciao

    Commento di ricochet — novembre 30, 2007 @ 6:30 pm

  58. AIUTO!
    Ho provato di tutto! Ma ho ancora i fastidiosi flash neri random! Ho una scheda Nvidia GeForce Go 7300 e gli ultimi driver 169.04 (beta).
    Che devo fare? Ogni volta che faccio lo scrolling su Firefox si paralizza per qualche secondo e poi incomincia a dare flash neri random.
    Con o senza Compiz inserito! Uffa!

    Che devo fare?

    Commento di Giancarlo — dicembre 4, 2007 @ 3:32 pm

  59. Ho gutsy e ho cercato di seguire la procedura passo passo, Purtroppo non riesco ad installare il driver (sudo sh NVIDIA-Linux-x86-71.86.01-pkg1.run -a -n -N): il messaggio di errore si riferisce al fatto che non vengono trovati i sorgenti del kernel.
    Dal gestore adept vedo installato il pacchetto linux-source-2.6.22.
    Dove sbaglio?
    Grazie in anticipo

    Commento di Max — dicembre 16, 2007 @ 6:00 pm

  60. @Max:
    punto 2 installa
    sudo apt-get install linux-headers-$(uname -r)
    quelli sono gli header del kernel.

    Commento di telperion — dicembre 16, 2007 @ 6:15 pm

  61. ops! pensavo di averlo selezionato da adept… è proprio vero che usare l’interfaccia grafica spesso non è molto utile.
    cmq ora l’installazione del driver mi da alcuni errori:

    ERROR: File ‘/usr/lib/xorg/modules/extensions/libglx.so’ is not a symbolic link.

    ERROR: Unable to create ‘/lib/modules/2.6.20-16-generic/volatile/nvidia.ko’ for copyng (no such file or directory)

    mi sembra molto strano visto che la mia attuale versione del kernel è la 2.6.22-14-386

    Al riavvio del server x mi compare l’errore relativo alla mancanza del nvidia kernel module

    Farò qualche altro tentativo…

    Commento di Max — dicembre 16, 2007 @ 6:57 pm

  62. @Max
    il primo errore viene corretto dall’installer, è normale perchè la libglx di nvidia è diversa.

    Il secondo è perchè non hai installato restriced-manager e linux-restricted-modules
    obbligatori su Gutsy se no non compila i driver.

    Leggi attentamente il punto 4.

    Commento di telperion — dicembre 17, 2007 @ 12:13 am

  63. ottima guida !
    complimenti

    grazie L

    Commento di luca — dicembre 18, 2007 @ 3:00 pm

  64. Ma se volessi rimuovere i driver installati con questa guida come faccio?
    Grazie mille per l’aiuto

    Commento di jubbaman — dicembre 21, 2007 @ 5:33 pm

  65. C’è scritto nell’appendice:

    Come rimuovere questo driver?
    sudo sh NVIDIA-Linux-x86-1.0-9755-pkg1.run --uninstall

    ovviamente al posto di
    NVIDIA-Linux-x86-1.0-9755-pkg1.run
    devi mettere il file .run che stai utilizzando o successivi.

    Devi poi cambiare l’ xorg.conf mettendo un altro driver
    al posto di nvidia (nv vesa)

    Commento di telperion — dicembre 21, 2007 @ 6:00 pm

  66. Ti chiedo scusa..
    Non l’avevo visto..
    Grazie mille per la rapidità di risposta.

    Commento di jubbaman — dicembre 21, 2007 @ 6:10 pm

  67. Ho ricominciato da capo e ora funziona.
    Per l’installazione del driver ho usato:
    sudo sh NVIDIA-Linux-x86-1.0-9755-pkg1.run -a -n -N –x-module-path=/usr/lib/xorg/modules
    Ho un problema: il refresh del monitor è molto lento. Devo abilitare l’accellerazione hardware?
    Grazie ancora

    Commento di Max — dicembre 22, 2007 @ 5:27 pm

  68. Aggiungo:
    glxinfo |grep rendering
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

    Commento di Max — dicembre 22, 2007 @ 5:35 pm

  69. Devo dire che i driver beta 169.04 mi hanno fatto uscire dall’incubo dei blocchi continui del sistema dovuti all’incompatibilità tra i processori dual core e i driver nvidia del restricted manager. Ora funziona tutto a meraviglia. Li ho installati seguendo la tua guida, ma mi sono rimasti alcuni dubbi. Primo: ho creato lo script per reinstallare in caso di aggiornamenti e ora nella mia home, oltre alle altre cose, ho il driver 169.04, una cartella nvidia, da me creata, con lo stesso driver copiato dentro e lo script. Quest’ultimo devo metterlo all’interno della cartella nvidia o lo lascio fuori? Altra cosa: perché dici che la compilazione di un modulo per i driver nvidia, in caso di aggiornamento del kernel, può essere fatta da terminale, senza uscire dalla modalità grafica? Infatti, se il kernel viene aggiornato, il server X non dovrebbe funzionare, giusto? Perdonami, ma sono un newbie quasi totale, che non vuole perdere la stabilità finalmente raggiunta dopo mesi di imprecazioni e sbattimenti … Grazie!

    Commento di Fulvio — dicembre 23, 2007 @ 2:22 pm

  70. @Fulvio:
    lo script mettilo dove vuoi tanto il comando

    cd ~/nvidia

    nello script comunque va alla cartella nvidia nella tua home.

    Per il discorso del driver se aggiorni lo stesso kernel (tipo ubuntu) usi lo script che aggiorna anche i link che venfono “rotti” dall’installer.
    Se invece installi un nuovo kernel (2.6.23.12 ad esempio, che ti trovi al boot nel grub) allora compili il solo modulo da terminale in modalità grafica.

    Commento di telperion — dicembre 23, 2007 @ 3:48 pm

  71. Sorry. La risposta al problema l’avevi gia indicata in un post precedente:
    disintallare xserver-xgl.
    Ora funziona alla perfezione.
    Saluti

    Commento di Max — dicembre 24, 2007 @ 12:01 pm

  72. @telperion:
    un piccolo aneddoto: da quando sono su gutsy a 64 bit, molto poco, non mi sono preoccupato di compiz, nel senso che ho lasciato la configurazione standard, “effetti Normali” quindi, poi ieri m’è venuto il pallino di “inCubarmi” il Desktop e alla spunta di Effetti visivi/Personalizzato mi viene chiesto (ordinato?) di abilitare i Driver per l’acc. 3D ???? !!!!! ” perche’ ora che uso, un finto 3D ? e mi avete fatto i restricted-manager anche per la 2.6.23.10-gas?? ”
    Ubuntu che fai mi prendi peu cu$o ?!
    saluti
    e Bone Feste

    Commento di ricochet — dicembre 26, 2007 @ 9:44 am

  73. […] Update 26 Dic 2007: saltando a gutsy le cose sono andate in peggio, senza noapic il sistema si freeza ancor prima di vedere il prompt di gdm. Inoltre persiste un problema di IRQ (il #7 viene disattivato dal kernel dopo pochi minuti) e non serve a niente flashare il BIOS con l’ultima release ad oggi disponibile. Per di più su gutsy sembra abbia qualche problema con i binari nvidia presenti nei repository, facendo freezare xorg in maniera randomica per poi riprendersi dopo qualche istante. Aggiornando i driver con gli ultimi disponibili su nvidia.com il problema non sembra più ripresentarsi. Per l’aggiornamento è necessario seguire alcuni accorgimenti per via del restricted-manager, qui sembrerebbe spiegato bene come fare. […]

    Pingback di Gutsy Ubuntu Linux su HP pavilion dv6000 — dicembre 26, 2007 @ 11:05 am

  74. Nell’archivio dei driver nvidia non esiste la versione 1.0-9643 ma si fermano alla 1.0-9639.
    Non hanno aggiornato o è una svista dell’autore?

    Commento di skino — gennaio 24, 2008 @ 9:56 pm

  75. @skino:
    http://www.nvidia.com/object/unix.html

    Linux IA32
    Latest Version: 169.09
    Latest Legacy GPU version (1.0-71xx series): 71.86.04
    Latest Legacy GPU version (1.0-96xx series): 96.43.04

    Li viene segnalato ma poi in effetti non c’è.
    Non c’è neppure nell’ ftp

    ftp://download.nvidia.com/XFree86/

    Usa il 96.39.

    Commento di telperion — gennaio 24, 2008 @ 10:29 pm

  76. Bella guida ma -a -n -N queste opzioni a cosa servono? Ciao e grazie

    Commento di ugaciaka — gennaio 25, 2008 @ 5:48 pm

  77. Non mi trovo al punto in cui devo premere CTRL+ALT+F1. Non succede nulla!!!! Che cosa dovrebbe fare?

    Commento di Alex F. — gennaio 27, 2008 @ 3:33 pm

  78. @alex: tre tasti premuti INSIEME (contemporaneamete)
    commutano su uno schermo nero con caratteri bianchi che si chiama “console virtuale” da dove immettendo user e password puoi utilizzare linux senza usare il server grafico Xorg.

    Commento di telperion — gennaio 27, 2008 @ 6:40 pm

  79. @ugaciaka:
    sh NVIDIA-Linux-x86-*.run -A
    ti dice tutte le opzioni e significati.

    Commento di telperion — gennaio 27, 2008 @ 6:42 pm

  80. […] in: Varie — telperion @ 7:02 pm Compilando il kernel 2.6.24 alla debian come sempre, nel compilare ed installare il modulo dal pacchetto NVIDIA*.run sulla mia Sid, si verificano queste 2 […]

    Pingback di Kernel 2.6.24 e Nvidia 169-09 « Tecnologia e non solo — gennaio 27, 2008 @ 9:40 pm

  81. Ciao Teleperion, complimentissimi per il blog:)davvero completo, ogni giorno che passa mi rendo conto di quanto sia bella la comunità linux…ops stavo andando fuori tema…

    Volevo esporti un piccolo problema legato ai driver nvidia e compiz di cui ho installato l’ultima versione grazie allo script. Il problema che ho notato è questo: nella resa dei video, con la spunta in compiz options>indirect rendering, noto problemi di refresh verticali, quando c’è un immagine in movimento verso l’alto il video ha come dei tagli leggeri…penso quindi sia proprio un problem di sincronizzazione verticale dell’immagine. L’opzione indirect rendering con Nvidia è la migliore in fatto di resa di FPS che sono altissimi e compiz risulta essere fluidissimo con la pecca però di questo problema sui video. Se indirect rendering è disattivato il problema sulla resa dei video non c’è ed è prefetto ma si ha una drastica diminuzione di FPS che scende a circa 25, 30, bassa rispetto a quelli con opzione attiva (ho una NV 8500 gt).

    Le domande sono:
    – hai anche tu questo problema sui video e se si c’è un modo per risolverlo mantenendo attivo indirect rendering?

    In aggiunta: ho provato tutte le opzioni di sincronizzazioni presenti ad esempio in smplayer ed ho tentato di usare alri output oltre ad xv e nello specifico ho usato anche x11, gl, gl2…

    Graze dell’ aiuto e ancora complimenti per il blog.

    Commento di monolite — febbraio 8, 2008 @ 11:34 am

  82. @monolite:
    con nvidia non dovresti usare indirect rendering che è un’opzione per le schede che usano DRI (driver xorg oss) ma solo loose binding.
    Per aumentare gli fps prova da
    ccsm -> generali -> display settings
    a togliere la spunta da sicronizza con Vblank.
    Riavvia compiz, e chiudendo tutte le finestre e i programmi, solo con desktop ccsm e benchmark io ottengo 270 frame con una fx5600 su Athlon XP3200+ solo con loose binding.

    Nvidia ha il suo glx server interno, indirect rendering è un comando sbagliato perchè il driver nvidia non usa “indirect rendering” ma usa il suo.

    Commento di telperion — febbraio 8, 2008 @ 12:39 pm

  83. In effetti settato come dici tu la velocità è altissima ma rimae purtroppo il problema dei video…quella sorta di linee orizzontali che compaiono quando le immagini nei video vanno dal basso verso l’alto…
    Non riesco a capire che cosa sia ma penso a questo punto che sia proprio un problema dei driver nvidia con compiz attivo e loose binding in questo caso. A differenza della ati almeno con nvidia i video si vedono. Peccato per questo piccolo difetto spero che lo si migliori prima o poi. Ma a te si verifica o solo a me. Questo mi “premeva” sapere:)
    Grazie per la risposta.

    Commento di monolite — febbraio 8, 2008 @ 1:28 pm

  84. @monolite: forse intendi nei video interlacciati? Prova la funzione “deinterlaccia” nei player. Oppure prova a mandarli a tutto schermo
    settando l’opzione
    ccsm -> generali -> generale
    spunta la casella -> Annulla il reindirezzamento finestre schermo intero

    Se invece intendi i video “flash” tipo youtube ingranditi che si vedono da cane, sono proprio cosi di loro.

    Io non noto particolari/fastisiosi problemi con i video.
    Sto usando il 169-04 perchè i successivi colla mia fx5600 “perdono” a volte le texture e mi trovo con finestra o decorazioni “trasparenti”.

    Commento di telperion — febbraio 8, 2008 @ 2:50 pm

  85. ALlora risolto tutto:) inanzitutto ho reinstallato i driver nvidia con la tua ottima guida:) (finalmente ho abbandonato ENVY) GRAZIE…:) seconda cosa ho attivato il loose binding e senza vblank mi dava più di 600 FPS 🙂 esaggerato…a dir il vero; poi ho deselezionato dalle impostazione di nvidia setting sync to Vblank nella parte video texture adaptor e in openGl deselezionato la stessa opzione.
    Così facendo però rimaneva il problema che ti dicevo nei video…:) alla fine ho selezionato il Vblank nel ccsm ed ora è perfetto…fluidissimo e i video perfetti:)

    adesso compiz va alla perfezione senza nessun accenno di rallentamento.

    Penso che le opzioni Vblank di nvidia-settings cocciassero con quelle di compiz.:)
    Ora è na scheggia:)

    Porca miseria ho appena vsto che hai aggiornato lo script makefusion ed io avevo rifatto tutto prima:)…ma pensa te:)
    Grazie ancora per la disponibilità…

    Commento di monolite — febbraio 8, 2008 @ 3:54 pm

  86. @monolite:
    io ho in nvidia settings
    X server XVideo setting – video textures adapt – Synch VB -> YES
    OpenGL Settings – Sy VB -> NO ed Allow flipping -> NO

    quello del ccsm -> generali Synch VB -> NO.

    Poi se ti funziona bene con la combinazione che hai trovato tieni quella.

    Commento di telperion — febbraio 8, 2008 @ 4:23 pm

  87. Salve a tutti,
    io ho Kubuntu Gutsy (KDE) funziona tutto fino a
    sudo /etc/init.d/kdm stop
    ottengo solo una schermata nera e devo riavviare…
    Mi piacerebbe tanto poter usare la mia GeForceGo 7300.
    Grazie.

    Commento di MrE — febbraio 8, 2008 @ 6:47 pm

  88. @MrE:
    nei casi disperati magari prova con ENVY
    evidentemente la risoluzione/refresh della console non sono corrette, sapere perchè rasenta conoscere i 6 numeri del superenalotto.
    Provato a fare CTRL+ALT+F1 (tre tasti contemporaneamente)
    dovrebbe apparire un terminale nero con scritto login#.
    Se non appare scarica ENVY e prova con quello.

    Commento di telperion — febbraio 8, 2008 @ 7:09 pm

  89. CTRL+ALT+F1 mi porta al terminale, riesco a fare il login, ma quando inserisco
    sudo /etc/init.d/kdm stop
    e do invio viene fuori la schermata nera…

    Commento di MrE — febbraio 11, 2008 @ 9:37 am

  90. OK, OK…
    dalla schermata di login grafico ho chiesto di entrare sulla console anzichè in modalità grafica e sembra che così io possa installare NVIDIA*.run…
    speriamo bbbbbbene…
    grazie.

    Commento di MrE — febbraio 11, 2008 @ 9:48 am

  91. grazie mille! le avevo provate tutte prima di questa guida! ora mi sa che perderò le mie giornate a far girare i cubi… 🙂

    Commento di turboneno — febbraio 28, 2008 @ 9:19 am

  92. ciao, la guida funziona, ma ho comunque un problemone, allora
    se non installo la skeda grafica, mi va tutto a rilento, devo installarla
    se la installo male, funziona qualcosa, qualcosa no.. non vabene
    se seguo questa guida, installo bene, mi esce il logo nvidia all’accensione ma,
    non mi fa accedere

    allora, carica ubuntu, arrivo alla skermata di login, user carlo, password jax55 enter..

    carica.. dopo un 5 secondi mi ritorna alla maskera di login, mi ributta indietro, vedo ancora nvidia in grande a tutto skermo e poi login..

    qualcuno sa come mai? strano ho seguito super scrupolosamente alla lettera.

    Commento di carlo — febbraio 29, 2008 @ 2:39 pm

  93. @carlo
    sembra il tipico problema di link della libreria opengl “corrotto” da un aggiornamento di xorg o mesa.
    Prova da console virtuale semplicemente a reinstallare i driver:
    sudo killall gdm
    poi vai alla cartella che contiene i file .run
    cd /precorso/cartella_file
    poi
    sudo sh NV*

    Commento di telperion — febbraio 29, 2008 @ 2:52 pm

  94. procedimento ke ormai conosco benissimo =) provo subito e ti dico, x ora grazie

    Commento di carlo — febbraio 29, 2008 @ 3:06 pm

  95. ok l’ho fatto, al primo riavvio ha funzionato!

    domandina fast, appena ho finito di installare i driver da terminale, come da procedimento, esce skermata nera e una skermata di dialogo dove mi kiede di impostare il monito, sony sdm-51d analog, ed eventualmente la skeda grafica, io imposto il monitor ma la skeda grafica la lascio stare visto ke l’ho appena installata, giusto?

    Commento di carlo — febbraio 29, 2008 @ 3:13 pm

  96. Ciao. Ho seguito la tua guida per installare i driver per la mia scheda video, una geforce2 go (quindi driver legacy versione96.xx.xx).
    Però non vuole saperne di andare, non so davvero più cosa pensare.
    Ho fatto tutto quello che dicevi, quando ho riavviato la prima volta mi ha dato un errore del failsafeXserver (too many arguments). Allora ho editato il gdm.conf per commentare la riga appropriata. Però riavviando, è evidente che qualcosa non va, ci sono tantissimi artefatti e l’interfaccia è lentissima.
    Forse è un problema nel xorg.conf, dato che mi trovavo con la tastiera in inglese. Ho provato a guardare quello originale per modificarlo a mano ma non compare nemmeno la sezione “module”. Significa qualcosa? Adesso ho riabilitato i driver nv e messi quelli nello xorg.conf di backup, i vesa non vanno.
    Grazie

    Commento di Paolo — aprile 18, 2008 @ 11:08 pm

  97. @Paolo lancia
    sudo nvidia-settings
    con i driver nvidia installati e da li setta risoluzione e frequenza e salva l’xorg.conf che ti genera.
    Se non và rimuovi i driver e prova con envy (se hai ubuntu)
    alcune 2go se non ricordo male hanno problemi.
    La scheda è piuttosto datata, non so che dirti.

    Commento di telperion — aprile 19, 2008 @ 12:40 am

  98. Ti ringrazio per l’aiuto ma non c’è verso. Credo sia una di quelle malfunzionanti a questo punto, anche se stando al sito nvidia è compatibile con i legacy nuovi e con compiz (avevo già provato envy ma ho avuto dei grossi problemi).
    Ora però ho il problema che all’avvio di ubuntu mi dice che la lingua della tastiera e dei settaggi di gnome è diversa (inglese una e italiano l’altra). Sai in che sezione del xorg.conf c’è la parte riguardo latastiera? In preferenze ho già messo di default quella italiana.

    Grazie ancora

    Commento di Paolo — aprile 19, 2008 @ 2:00 pm

  99. Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbLayout" "it"
    Option "XkbModel" "pc105"
    EndSection

    ovviamente la riga della lingua è
    Option "XkbLayout" "it"

    comunque quando esce l’avviso basta dirgli usa le impostazioni di gnome e non chiedere più.

    Per la scheda esistono una marea di chip diversi assemblati dai produttori/distributori forse ti è capitato un modello prodotto in una serie limitata che non viene riconosciuto correttamente. Boh.

    Commento di telperion — aprile 19, 2008 @ 2:44 pm

  100. Ciao, ho beccato il tuo post per caso sono settimane che ci sto sfasando sopra i driver ma nn rieco ad installarli adesso proverò a seguire la tua guida spero che finalmente vada tt bn…speriamo

    Commento di teolloo — aprile 19, 2008 @ 2:59 pm

  101. Grazie dell’aiuto. Potresti aver ragione, forse la scheda è assemblata da altri produttori. Infatti nel sito nvidia non ci sono i driver per windows, per scaricarli ti rimanda al sito della acer che è il produttore del computer.
    Ho modificato la sezione della tastoera, vedrò quando riavvio. Il fatto strano è che invece mi chiedeva ogni volta la lingua anche se sceglievo le impostazioni di gnome.

    Commento di Paolo — aprile 20, 2008 @ 11:14 am

  102. Volevo avvisarti che ho risolto il problema (almeno in parte). Ho installato i driver dopo aver completamente rimosso il pacchetto linux-restricted-modules, quelli della nvidia dicono, come hai specificato te, di disabilitare il modulo nv. In caso di ulteriori problemi (cosa che loro dicono essere molto probabile) suggeriscono di rimuovere proprio il pacchetto.
    Rimosso il pacchetto che fu galeotto, ho reinstallato i driver e funziona tutto. E’ il gestore che da diversi problemi, forse dovresti aggiungere una nota nella guida in cui dici di rimuoverlo in caso ci siano ulteriori problemi, diciamo come ultima spiaggia.

    Commento di Paolo — aprile 21, 2008 @ 2:16 pm

  103. @Paolo
    fino alla Feisty si poteva, su Gutsy/Hardy se rimuovo i ristretti non si installa più il modulo nvidia (almeno i >100 quelli vecchi 70-90 non so).
    E poi magari altri ristretti magari servono (es. WiFi).
    Di solito il blacklist dei moduli è sufficiente, il tuo è un caso limite.

    Commento di telperion — aprile 21, 2008 @ 2:32 pm

  104. Mi sembra logico che il mio fosse un caso limite.. 😉
    Per il wifi ho usato i driver windows con ndiswrapper. Capisco che dire ad una persona che per installare i driver della scheda video abbia bisogno di fare diversi giri per avere funzionante anche la scheda di rete non sia il massimo, considerando che io ho dovuto spulciare l’archivio dei driver del produttore per trovare quello che funzionasse con ndiswrapper..

    Comunque sul forum di supporto della nvidia consigliano di rimuovere il pacchetto piuttosto che escludere i moduli. Purtroppo noi paghiamo la loro scelta di non permettere alla comunità di sviluppare driver open.

    Commento di Paolo — aprile 22, 2008 @ 8:59 am

  105. @Paolo:
    queste porcate succedono solo con Ubuntu è la sua “fantasiosa” gestione dei driver con restrizioni, su altre distribuzioni basta rimuove il pacchetto del driver ed installare il file .run e in 20 secondi sei a posto.
    Ora scaricare su Nvidia che fornisce invece un ottimo driver costantemente aggiornato, colpe che sono in questo caso esclusivamente del team Ubuntu, mi sembra troppo.
    Sta storia dei driver open ha veramente rotto.
    Vedi quelli di Ati che cagata sono i driver open (e anche closed).

    Commento di telperion — aprile 22, 2008 @ 10:28 am

  106. […] il recente 2.6.25 sulla Hardy tra i consueti slalom ubuntiani per poter compilare il modulo Nvidia (pacchetto […]

    Pingback di Hardy Heron e i kernel custom (2.6.25) « Tecnologia e non solo — aprile 22, 2008 @ 8:01 pm

  107. Non sono d’accordo: gli sviluppatori di ubuntu hanno fatto una scelta per gestire in una certa maniera alcuni tipi di driver. Molto probabilmente questa gestione va migliorata, però la nvidia deve prendere atto di ciò e assumersi l’onere di produrre driver compatibili. Altrimenti lasci lo sviluppo dei driver ad altre persone, non possono decidere di rilasciare driver che mi costringono a rinunciare a delle funzionalità del mio sistema operativo.

    Commento di Paolo — aprile 23, 2008 @ 9:54 am

  108. grazie per le info ho fatto tutto come specificato dalla tua guida
    in + appena ho riavviato ho dovuto inserire a mano la modalità del mio monitor
    samsung SyncMaster 205BW perchè era fissa su 640×480. Adesso mi godo appieno il mio 1680×1050
    complimenti 😉

    Commento di vcorp — aprile 24, 2008 @ 1:21 pm

  109. ho installato la HH sul mediacenter, ma i driver video nvidia new installati dal gestore di ubuntu mi fa casini, rileva solo le risoluzioni di 640 e 320 (quando il monitor supporta tutte le ris fino a 1280×720 e 1344×768)
    per mettere i driver manuali è cambiato niente dalla GG? Posso procedere con questa guida 🙂

    Commento di Attila16881 — aprile 26, 2008 @ 12:00 pm

  110. Attila sembra che su HH ci siano parecchi problemi con sta cavolo di risoluzione bassa e non si trovi il modo di venirne a capo. Se hai il vecchio xorg.conf ripristinalo.

    Su gome c’è
    displayconfig-gtk
    che forse può aiutare
    su kde non so.

    Commento di telperion — aprile 26, 2008 @ 1:16 pm

  111. Ragazzi, complimenti per la guida…
    cmq ho un problema (che ho avuto anche usando Envyng qt) mi è impossibile settere una risoluzione pari a 1024×768 (sicuramente supportata dal mio lcd) xchè la massima disponible in nvidia x setting è 640×480….
    Ho Kubuntu 8.04 di aprile stabile
    grazie se vorrete aiutarmi…..

    Commento di Gio — aprile 28, 2008 @ 4:55 pm

  112. @Gio
    prova con

    sudo gedit /etc/X11/xorg.conf

    ad aggiungere dentro la Section “Screen”
    la riga:

    Option "metamodes" "1024x768 +0+0; 800x600 +0+0"

    poi salva e riavvia.

    Se riparti a 1024×768 lancia poi da terminale:
    sudo nvidia-settings

    Clicca X server Display configuration
    fai detect display regola risoluzione frequenza
    apply per provare, quando è tutto a posto
    save to x configuation file -> merge existing file.

    Commento di telperion — aprile 28, 2008 @ 5:22 pm

  113. utilizzando il cavo dvi la risoluzione viene rilevata correttamente (faccio presente che installati i driver gestiti da ubuntu 8.04)
    il problema è che non riesco a settare le dimensioni in altezza e larghezza del monitor, in pratica non vedo ne le barre sopra e sotto e inoltre risulta anche un po troppo largo.
    Ho provato a settare manualmente usando xvidtune e poi editando xorg.conf ma niente, questo nuovo xorg ha le varie voci “configurate” e la ubuntu sembra non filarsi di pezzo i cambiamenti che vado a fare o le opzioni che vado ad aggiungere a quelle voci… c’è un modo per editare questo diavolo di schermo? non è possibile che il pannello di settaggi non me lo fa fare e manualmente non posso modificare niente su xorg.conf

    Commento di Attila16881 — maggio 2, 2008 @ 6:06 pm

  114. @Attila16881
    usa
    sudo nvidia-settings
    setta risoluzione e frequenza schermo da li
    premi applica per vedere come risulta
    e poi salva l’xorg
    save to x configuation file -> merge existing file.

    vedi appendice aggiunta
    Settare xorg.config con nvidia-settings.

    Nvidia fornisce un tool apposito, basta usare quello.
    Le applet di linux vanno bene solo per i driver oss di xorg e basta.

    Se usi i driver Nvidia dei pacchetti Ubuntu
    installa nvidia-settings

    sudo apt-get install nvidia-settings

    se invece installi dal file .run hai già tutto.

    Commento di telperion — maggio 2, 2008 @ 6:55 pm

  115. Grazie per l’aiuto, ho fatto tutto come dalla tua guida ed è andato tutto liscio!

    Commento di krenz — maggio 8, 2008 @ 10:42 am

  116. Ciao, complimenti per la guida, è davvero comprensibile ma ho comunque un problema… Ho seguito tutto passo passo, ma arrivato al punto 5, dopo aver spento il server X quando lancio il comando sh NVIDIA-ecc… mi dice che il server X non è spento e non mi fa andare più avanti. Come posso risolvere? Grazie.

    Commento di Matteo — maggio 13, 2008 @ 3:08 am

  117. @Matteo
    Probabilmente non hai disattivato BulletProof-X failsafe mode
    che fa quell’effetto li oltre ad altre brutture.

    O lo disattivi come indicato al punto 4 oppure usi l’opzione

    --no-x-check

    esempio:

    sudo sh NVIDIA-Linux-x86-169.12-pkg1.run -a -n -N --no-x-check

    Commento di telperion — maggio 13, 2008 @ 10:19 am

  118. […] informazioni prese da: Tecnologia e non solo (Articolo Senza Voto)  Loading … 1 letture Stampa questa pagina Postato […]

    Pingback di Guide e Manuali Linux e Windows - Installare Driver Nvidia — maggio 14, 2008 @ 10:54 am

  119. Ciao Telperion !
    Grazie infinite per la tua guida. Finalmente ho risolto la maggior parte dei problemi,….assolutamente la migliore guida e di gran lunga favolosamente spiegata.
    Vorrei chiederti un consigio. Sto usando una Nvidia fx 5600xt e adesso (grazie a te) funzione egregiamente anche con ubuntu, ma ho un dubbio, non so se sbaglio qualcosa o se esiste qualche incompatibilitá. Mi siego:
    Ho installato i drivers senza errori, la risoluzione del monitor lcd é quella desiderata (1280×1024) il refresh pure, (60 hz)
    e l’uscita video funziona ma ad esempio se riproduco un film con VLC il filmato viene riprodotto oltre lo schermo della televisione (sony bravia) che dovrebbe essere 1024×768 mentre sul monitor del pc si vede egregiamente a tutto schermo. Idem con Gstreamer mentre con Mplayer la riproduzione si adatta perfettamente alla grandezza dello schermo tv.
    Qualche consiglio ?
    Grazie in anticipo.

    Commento di Nick — maggio 19, 2008 @ 5:55 pm

  120. Nick:
    putroppo sull’uscita tv è un pò un pasticcio.
    Visto che con Mplayer va bene usa quello, oppure prova con sudo nvidia-settings a settare separate x-screen e vedi se la situazione migliora (fai un backup di xorg.conf prima).
    Ti confesso che i film io li guardo da windows, la gestione della scheda da lì è molto più sofisticata..

    Commento di telperion — maggio 19, 2008 @ 7:01 pm

  121. Ciao Telperion….grazie per la tua risposta a dir poco immediata.
    Ho provato a fare varie prove proprio con “sudo” per il sospetto che ho che non salvi i cambiamenti, ma nulla da fare. Ho osservato che con VLC e Gstreamer la riproduzione dei filmati sull’uscita TV viene fatta con la stessa proposzione in cui appare la dimeensione del TV sulla schermata di configurazione (mi riferisco ai 2 rettangoli che rappresentano Monitor e TV).
    Poi non so se é una mia impressione, ma credo che mplayer riproduca meglio di VLC o per meglio dire, VLC non é cosí efficente come nella sia versione per Windows.
    Cambiando discorso, ormai sono circa 15 gg. che uso stabilmente Ubuntu, ma ho la sensazione che sia rallentato moltissimo. La gestione dell’audio credo che sia inferiore a Windows, infatti non riesco a far funzionare due riproduttori insieme visto che il dispositivo audio viene usato in modo esclusivo dal primo che lo occupa….mahhhh….
    Comunque é bello scambiare idee ed esperienze.
    Grazie di nuovo e a presto rileggerci.
    Saluti a tutti i frequentatori del blog.
    Ciao !

    Commento di Nick — maggio 20, 2008 @ 10:41 am

  122. ottima guida, veramente ottima….

    Commento di pieddu — maggio 27, 2008 @ 8:24 am

  123. grazie

    Commento di telperion — maggio 27, 2008 @ 7:36 pm

  124. Ciao, sono un nuovo utilizzatore di Ubuntu e in particolar modo di Hardy.
    Il mio unico problema, dopo l’installazione, sono stati i famigerati driver per la mia scheda video Nvidia GeForce 6200 Turbo Cache. Ho seguito attentamente la tua guida (tralaltro molto chiara) ma al riavvio non viene caricato più il sistema grafico, dando una risposta che mi indica di cambiare la configurazione del server X. In pratica non entro in Gnome… credo.
    Prima di reinstallare il s.o. e tenermi la risoluzione di defoult, puoi suggerirmi qualcosa?
    Ripeto durante la procedura tutto ok ma al riavvio assolutamente non vuole saperne di andare avanti. I driver che ho scelto sono i 173.14.05
    Puoi aiutarmi?

    Grazie in anticipo.

    CIAO.

    Commento di Stefano — giugno 4, 2008 @ 2:17 pm

  125. Ciao Teleperion !
    Di nuovo un saluto ed un ringraziamento per la tua disponibilita.
    Volevo chiederti un consiglio o una dritta per un problemino che ho.
    Ho risolto la questione dei driver Nvidia ed in pratica funziona quasi tutto alla pefezione (grazie alle tue indicazioni) ma adesso ho notato una cosa un pó strana. Quando apro FireFox, Nautilus o qualsiasi applicazione come ad esempio anche googleEarth si aprono sempre con la diensione dell’uscita virtuale TV….e come se avessi un monitor dentro un monitor, non so se riesco a spiegarmi. La risoluzione del monitor é 1240×1024 e quella dell’uscita tv e 1024×768 che sovrapposta virtualemte al monitor occupa circa 3/4 dello schermo, ebbene le applicazioni si aprono a 3/4 dello schermo e devo sempre ingrandirle con il mouse e poi a volte se ci clicco sopra si riducono di nuovo alle dimensioni di partenza…..mahhhhh
    Qualche idea ?
    Grazie….
    P.D. Non essendo un buon cuoco ma solo un cuoco, vado nei migliori ristoranti per apprezzare chi fa meglio di me.

    Commento di Nick — giugno 5, 2008 @ 9:37 am

  126. Col kernel 2.6.25 su SID ho dovuto ricompilarlo togliendo la Paravirtualizzazione.

    Commento di stefanauss — giugno 17, 2008 @ 12:25 am

  127. @stefanauss:
    non so, io la paravirtualizzazione ho disattivata da una vita, tanto per quel che serve.

    Commento di telperion — giugno 19, 2008 @ 11:42 pm

  128. Grazie Telperion, alla fine ho risolto!!
    Con la tua guida, ovviamente! 😉

    Commento di aleida — giugno 21, 2008 @ 8:19 pm

  129. @aleida:
    meno male, son contento, sempre detto con “garbatezza”.
    😉

    Commento di telperion — giugno 22, 2008 @ 12:37 pm

  130. Sei grande! Mi hanno installato ieri la 9600 gt e stavo diventando matto con envy e tutta quella serie infinita di driver in Synaptics. Poi, finalmente ho scoperto lo stupendo lavoro che hai fatto ed in un baleno mi sono trovato con il driver installato. Grazie!
    Ho avuto un attimo di perplessità nel punto in cui tu dici:

    trovate le righe:
    # This runs Ubuntu’s BulletProof-X failsafe mode.
    FailsafeXServer=/etc/gdm/failsafeXServer

    e cambiatele in

    # This runs Ubuntu’s BulletProof-X failsafe mode.
    # FailsafeXServer=/etc/gdm/failsafeXServer

    Io ho trovato solo la seconda riga, ma non la prima; ho aggiunto il cancelletto e basta. E’ giusto cosi’ o c’ e’ qualcosa che non va da me?
    Poi ancora, e lo vedi da come scrivo, e’ cambiata la configurazione della tastiera ed i simboli {punti, due punti, parentesi, ecc.} sono fuori posto; ho lanciato dpkg reconfigure xserver xorg, con i trattini relativi che qui mancano, ma tutto sembrava a posto. Hai qualche idea?

    Commento di Roberto — giugno 26, 2008 @ 10:41 pm

  131. Ho seguito la tua guida sono riuscito ad installare i driver(quelli dal sito di nvidia per una nvidia geforce 9500 gs montata su un asus PRO57Sseries), va tutto bene tranne che quando riavvio la risoluzione invece di essere settata a 1280×800 si setta
    a 1280×768 inoltre avviando da root nvidia-settings mi appaiono questi errori

    root@gux:/home/gux# nvidia-settings

    ERROR: Cannot open display ‘gux:0.0’.

    ERROR: Unable to assign attribute DigitalVibrance specified on line 21 of configuration file ‘/root/.nvidia-settings-rc’ (no Display
    connection).
    ….

    potresti darmi qualche consiglio per risolvere il problema!

    Commento di gux — luglio 8, 2008 @ 3:59 pm

  132. @gux
    non devi avviarla da root, devi usare sudo o su o gksudo o gksu dal tuo utente, l’utente root di solito non ha interfacce grafiche quindi ERROR: Cannot open display ‘gux:0.0′.

    Commento di telperion — luglio 8, 2008 @ 4:26 pm

  133. Grazie infinite per il tuo consiglio hai ragione che non va avviato da “root”!.
    Adesso va tutto a meraviglia e posso godermi programmi come blender compiz etc….
    Grazie ancora per la tua splendida guida.

    PS:ho risolto il problema del video che si settava a 1024×768 seguendo il consiglio dato al commento num_112

    Commento di gux — luglio 9, 2008 @ 12:39 pm

  134. Eccoci di nuovo qui con un nuovo quesito. Spero tu sia rientrato dalle ferie, telperion 😀
    Il gestore aggiornamenti mi propone di installare nvidia-glx, oltretutto lo classifica come “aggiornabile”, quando invece sarebbe da reinstallare ex novo, visto che l’avevo eliminato prima di installare i driver proprietari.
    Ritengo che non debba dargli retta al gestore aggiornamenti, giusto?
    In tal caso, come faccio a dirgli di scaricare tutti gli altri pacchetti eccetto quello?

    ps: se telperion fosse ancora in ferie, può sempre rispondermi qualcun altro 😉

    Commento di aleida — agosto 24, 2008 @ 1:50 pm

  135. problemone su un pc che ho assemblato: xp2000+ 1gb ram nvidia fx5600, monitor nuovo benq g200wa (1680×1050)
    installata hardy, funziona tutto perfettamente… vado ad attivare i driver video col gestore, riavvio: monitor out of range niente…
    allora ripulisco tutto e installo envyng, configura tutto, riavvio, e di nuovo monitor out of range
    allora provo con la config manuale seguendo questa guida come sul mio pc, riavvio e mi da errore nella config di xorg dice no screen found quando si avvia gnome.
    cercando ho trovato questi 2 topic ma anche settando la risoluzione a 640×480 (per cambiare la risoluzione dopo con displayconfig-gkt) installando i driver in qualsiasi modo, riavvio e non funziona di nuovo… cosa puo essere?

    posso vedere la configurazione che viene fatta automaticamente con reconfigure xserver-xorg (su xorg.conf non compare ovviamente ma ci sono le solite voci configure monitor, device ecc dove diavolo le mette le configurazioni???) per i driver vesa che funziona correttamente invece? cosi controllo quali sono le impostazioni del monitor che funzionano e le setto manualmente.

    ecco i topic che ho trovato a riguardo:
    http://forum.ubuntu-it.org/index.php?topic=210556.msg1424768
    http://ubuntuforums.org/showthread.php?t=832943

    Commento di Attila16881 — agosto 27, 2008 @ 9:35 am

  136. quando mi fa l’errore “no screens found” l’output del serverx è il seguente

    (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
    (EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
    (EE) NVIDIA(0): that the NVIDIA device files have been created properly.
    (EE) NVIDIA(0): Please consult the NVIDIA README for details.
    (EE) NVIDIA(0): *** Aborting ***

    e poi fa l’unload dei drivers e mi da l’errore no screens found

    Commento di Attila16881 — agosto 27, 2008 @ 11:30 am

  137. @Attila16881
    Le GeForce FX (serie 5) sono supportate dai driver 173.14.xx o precedenti, per il resto ormai Ubuntu è un vero casino, se hai un vecchio xorg.conf usa quello e metti “vesa” nel driver.

    Commento di telperion — agosto 30, 2008 @ 4:08 pm

  138. Ho seguito la guida per installare il pacchetto NVIDIA-Linux-x86-173.14.12-pkg1.run, ed ho un solo problema, se così lo si vuol chiamare, quando nell’installer chiede se voglio configurare in modo automatico Xorg io ho risposto si, però questo mi ha cambiato la disposizione della tastiera ma ho già riparato, pero il touchpad del portatile fa le bizze in quanto non funziona più lo scrolling orizzontale e verticale, e poi non mi permette di usare la combinazione tasto dx e sx premuti contemporaneamente.

    Commento di g_best — settembre 6, 2008 @ 1:26 pm

  139. Aggiornamento ho risolto seguendo questa guida alla configurazione di Xorg
    http://www.pikkio.net/blog/20070729/touchpad-ubuntu-feisty/

    Commento di g_best — settembre 6, 2008 @ 4:49 pm

  140. Questo link non funziona più… almeno, io non riesco a caricare la pagina con nessun browser:

    http://www.nvidia.com/object/unix.html

    Per vie traverse sono arrivata al sito da cui scaricare i driver adatti alla mia GeForce4, questo:

    http://www.nvidia.it/object/linux_display_ia32_100.14.11_it.html

    però la cosa assurda è che riesco solo a scaricare, e con segnalazione di errori, il file binario.

    O.o

    Commento di aleida — settembre 9, 2008 @ 11:08 am

  141. @aleida
    capita che i siti a volte siano down, ieri nvidia.com non andava, oggi va perfettamente. È internet, è sempre stato così.

    Commento di telperion — settembre 9, 2008 @ 1:15 pm

  142. Vero il sito ieri era down (pure stamattina) e ora invece va, però il pkg che m’interessa continua a non scaricamelo. Mah, staranno facendo manutenzione, comunque se t’interessa, posso vedere tutto il contenuto del pkg 😉 Finalmente è opensource! 😀
    (mi si apre il binario nel browser stesso..)

    Commento di aleida — settembre 9, 2008 @ 3:49 pm

  143. @Aleida
    ma per geforce4 non dovrebbe essere
    Linux Display Driver Version 96.43.07 NVIDIA Recommended
    vedi un po col search
    http://www.nvidia.com/Download/Find.aspx?lang=en-us

    “Mah, staranno facendo manutenzione, comunque se t’interessa, posso vedere tutto il contenuto del pkg 😉 Finalmente è opensource!”

    No è firefox che toppa,
    sul link “accetti” tasto destro – salva destinazione con nome

    Commento di telperion — settembre 9, 2008 @ 5:04 pm

  144. @ telperion:
    Con la ricerca mi vengono fuori entrambi. Quello del link che ho postato io è un aggiornamento del 21 luglio, quello precedente era del 17 luglio.
    Ma va benissimo anche il 96.43.07, infatti me lo tengo.

    Non uso FF, però ho provato a fare come hai detto con Iceweasel e ha funzionato 🙂

    Anche se avevo già risolto con wget 😉

    Commento di aleida — settembre 11, 2008 @ 2:44 pm

  145. Iceweasel =
    FF + patch debian che non consentono di usare il nome originale.

    Commento di telperion — settembre 11, 2008 @ 3:06 pm

  146. Io quando provo ad eliminare i driver nvidia mi da un errore,ovvero:

    Rimuovo nvidia-glx-new …
    dpkg-divert: errore controllando `/usr/lib32/libGL.so.1′: Nessun file o directory
    dpkg: errore processando nvidia-glx-new (–remove):
    il sottoprocesso post-removal script ha restituito un codice di errore 2
    Sono occorsi degli errori processando:
    nvidia-glx-new
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Cosa posso fare???

    Commento di Leo — settembre 11, 2008 @ 7:51 pm

  147. Leo prova a cancellare il file
    /var/lib/dpkg/info/nvidia-glx-new*.postrm
    e poi fai
    sudo apt-get -f install

    Commento di telperion — settembre 12, 2008 @ 2:36 pm

  148. Un consiglio per chi usa password complesse per il proprio account, ovvero di impostare subito il layout in italiano per la tastiera, prima di riavviare il server grafico, altrimenti sarà difficile loggarsi. Questo perchè, l’installer nvidia riscrive xorg.conf lasciando un…tacito, layout en_US.
    Quindi,

    sudo nano /etc/X11/xorg.conf

    e aggiungere nella sezione

    Section “InputDevice”
    Identifier “Generic Keyboard”

    questo:

    Option “XkbLayout” “it”

    salvare con ctrl+O (non è uno zero, ma una O), chiudere con ctrl+X

    Commento di shosholoza — ottobre 6, 2008 @ 2:41 pm

  149. domenico@domenico-laptop:~$ glxinfo|grep render
    direct rendering: Yes
    OpenGL renderer string: GeForce Go 7950 GTX/PCI/SSE2
    GL_NVX_conditional_render, GL_SGIS_generate_mipmap, GL_SGIS_texture_lod,

    grazie mille sembra esser andato tutto benissimo….unica mia perplessita e’ che credo che mi sfochi troppo
    le finestre quando le muovo….puo’ essere una mia impressione?

    ho installato questi driver NVIDIA-Linux-x86-177.80-pkg1.run

    ciao 😀

    Commento di Domenico — ottobre 10, 2008 @ 12:16 pm

  150. Ciao è grazie per le preziose informazioni contenute in queste pagine.

    Mi sono avvicinato da poco al mondo Linux e devo dire che non ho avuto grossi problemi.

    L’unico problema che non riesco a risolvere e non riesco nemmeno a trovare qualcuno che lo abbia risolto è il seguente.

    Ho un portatile Dell Latidude D830 con una nVidia Quadro NVS 140M NVIDIA e il driver ver. 177.80.
    Purtroppo, quando attivo compiz, ho alcuni problemi (la cui intensità si moltiplica quando uso un monitor aggiuntivo) del tipo, icone sul desktop che non si spostano (o meglio, si spostano ma non si aggiorna la loro visualizzazione), a volte le finestre vengono caricate in maniera parziale e devo passarci su con il mouse per refresharle.

    Grazie
    Carlo

    Commento di nemiax — ottobre 17, 2008 @ 11:01 am

  151. @nemiax
    vedi qui
    https://telperion.wordpress.com/2008/10/15/se-sparta-piange-atene-non-ride/

    Commento di telperion — ottobre 17, 2008 @ 11:19 am

  152. Ciao telperion,
    kubuntu ha cambiato il kernel dalla versione 2.6.24-19 alla 2.6.24-21
    mi aspettavo di dover reinstallare i driver, e invece niente…
    voglio dire, meglio così! però mi chiedo, come mai?

    Commento di aleida — ottobre 17, 2008 @ 10:36 pm

  153. @aleida
    perchè se sono patch di aggiornamento di ubuntu installano tutto nella stessa cartella (vedi in /lib/modules) e quindi il modulo nvidia li c’è.
    Se invece installano i moduli in una nuova cartella ovviamente il modulo va ricompilato.

    Commento di telperion — ottobre 17, 2008 @ 11:49 pm

  154. ah… quindi se ho capito bene, qualora si tratti di patch me ne accorgerò dalla cartella in cui si andranno a installare (/lib/modules); diversamente saprò che l’aggiornamento è un nuovo modulo e quindi dovrò reinstallare i driver. ecco, buono a sapersi, grazie! 🙂

    Commento di aleida — ottobre 18, 2008 @ 1:38 am

  155. Ciao, premetto che questa guida mi ha aiutato in un sacco di occasioni quindi grazie grazie e grazie ancora per il lavoro fatto!
    Ieri ho provato a seguire questo procedimento per installare i driver su intrepid.
    Ho una nvidia 8300 gs e i driver che ho installato sono i 177.80 scaricati dal sito nvidia.
    Risultato che, una volta riavviato gdm dopo aver modificato xorg.conf, le icone, il puntatore, tutto ciò che è sul video inizia a lampeggiare fastidiosamente.

    Aspetto fiducioso un aiutino.
    Grazie

    Commento di marco — novembre 4, 2008 @ 10:14 am

  156. @marco
    intrepid con nvidia è piena di problemi

    https://telperion.wordpress.com/2008/10/15/se-sparta-piange-atene-non-ride/

    Puoi anche disinstallare i driver .run e installare i 177 di ubuntu che sono gli stessi, prova.

    Commento di telperion — novembre 4, 2008 @ 12:24 pm

  157. si infatti ho già provato ad abilitarli da ubuntu ma ottengo lo stesso risultato (infatti se sono gli stessi…).
    Domanda: per abilitare i driver da ubuntu devo tornare alla situazione iniziale oppure posso farlo avendo proceduto nei punti 2) 3) e 4)?
    Io l’ho fatto dopo aver proceduto in quei punti.

    Ciao e grazie

    Commento di marco — novembre 4, 2008 @ 1:07 pm

  158. Per tornare ai driver ubuntu
    nell’ordine:

    sudo gedit /etc/default/linux-restricted-modules-common

    togliere nv nvidia_new nella riga DISABLED_MODULES=

    DISABLED_MODULES=""

    poi disinstallare il .run

    sudo sh NVIDIA-Linux-*.run --uninstall

    quindi reinstalli il pacchetto

    sudo apt-get install nvidia-glx-177

    Commento di telperion — novembre 4, 2008 @ 2:17 pm

  159. Ok mi hai tolto un dubbio che avevo da tempo.
    Comunque nel frattempo ho risolto!!
    Se può essere utile a qualcuno ho installato i driver per la nvidia 8300 gs, con sh, come da guida (paro paro).
    I driver in questione sono i 177.80 scaricati appunto dal sito nvidia.
    Successivamente nel menu compizconfig nella sezione “gestore finestre” ho inserito “usr/bin/compiz-decorator” che sarebbe la riga di default che però io avevo modificato per far funzionare gli effetti in hardy con “compiz –replace &”.
    Anche per questa volta è andata!!
    Ciao, per l’ennesima volta.. Grazie 😉

    Commento di marco — novembre 4, 2008 @ 3:25 pm

  160. ciao a tutti, io ho installato il driver, ma mi sono accorto che nelle impostazioni del colore, non funziona la brillantezza digitale.
    Vorrei sapere se è normale o pure meno, se no come si può impostarla?.Io se aumento o diminuisco non cambia nulla.
    Vi ringrazio in anticipo ciao a tutti

    Commento di akille — novembre 15, 2008 @ 2:00 am

  161. GeForce 7300 GS su Ubuntu 8.04. Vorrei sfruttare la mia vecchia tv per vedere i film che ho nel pc. Sotto Windows nessun problema; con Ubuntu, attraverso il software di controllo Nvidia (nvidia-settings), riesco a settare la modalità “separate X screen” (il televisore ha una risoluzione diversa rispetto al monitor del pc) e a far comparire il desktop, con i pannelli, ma senza le icone, sullo schermo tv. Quando però lancio un filmato (per esempio con Vlc), lo vedo solo sullo schermo del pc e non so come spostarlo sulla tv. Qualcuno può aiutarmi?

    Commento di Fulvio — novembre 28, 2008 @ 4:08 pm

  162. @Fulvio
    io ci ho rinunciato, troppo casino e risultati MOLTO inferiori a windows, se devo vedere un film sul TV booto windows e con nview lo vedo PERFETTAMENTE.

    Commento di telperion — novembre 28, 2008 @ 6:50 pm

  163. […] Fonte principale: qui. […]

    Pingback di Ubuntu e Nvidia « bloide* - the Jaunty Blog — dicembre 9, 2008 @ 4:32 am

  164. Ciao Telperion, ho bisogno di un chiarimento. Siccome risulta comoda ad ogni cambio del kernel la ricompilazione automatica dei driver installati dai repo, sai dirmi se tutt’ora bisogna ricompilare a mano quelli prelevati dal sito ufficiale ad ogni cambio del kernel?

    Commento di aldolat — gennaio 17, 2009 @ 12:54 pm

  165. @aldolat
    se usi il run di nvidia e se il nuovo kernel cambia la dir /lib/modules dove installa i moduli bisogna ricompilarlo, altrimenti no.
    Se cambia la cartella dei moduli comunque è come fosse un nuovo kernel quindi puoi usare con il kernel precedente il comando

    sudo sh NVIDIA-Linux-x86-numeroversionedriver-pkg1.run -K --kernel-name=2.6.20-16-generic

    dove in kernel-name= metti il nome del nuovo kernel, che compila solamente il nuovo modulo.

    Inoltre ad ogni aggiornamento di
    xserver-xorg-core e libgl1-mesa-glx
    vengono cambiati i link simbolici delle libgl che invece che puntare alla libreria nvidia puntano alla mesa, e per ripristinarli bisogna reinstallare di nuovo il driver completo.

    Commento di telperion — gennaio 17, 2009 @ 1:55 pm

  166. grazie mille! 🙂

    Commento di aldolat — gennaio 17, 2009 @ 2:13 pm

  167. Io sono disperato, proprio non riesco. Se qualcuno volesse dare un’occhiata e provare ad aiutarmi gli sarei eternamente grato.
    Ho spiegato tutto qui

    http://forum.ubuntu-it.org/index.php/topic,255327.0.html

    Commento di Ettore — gennaio 28, 2009 @ 8:54 am

  168. ho provato ad installare i driver, ma durante l’installazione esce questo errore:
    unable to open /usr/lib/nvidia/libglx.so.xserver-xorg-core
    oppure è apparso anche solo
    unable to open /usr/lib/nvidia/libglx.so

    con la versione precende mi sembra tipo la .18 o .20 tutto ok

    Commento di neorf — febbraio 6, 2009 @ 4:32 am

  169. Ciao e complimenti per l’ottima guida.
    L’ho sfruttata dia per Ubuntu 8.04, che successivamente per la 8.10, con risultati perfetti. Perciò grazie ancora.

    Ieri ho eseguito l’ennesimo aggiornamento del sistema (ubuntu 8.10), notando che avrebbe aggiornato i moduli del kernel alla 2.6.27-13.
    Già immaginavo di dover reinstallare i driver NVIDIA, e ho recuperato i fogli che ho stampato, con la presente guida.

    Bello tranquillo, faccio il mio aggiornamento, e dopo, ovviamente, si pianta xserver.
    Dopo vari tentativi, riesco a far ripristinare i drivers standard di ubuntu, e inizio la procedura per l’installazione dei driver originali.
    Scarico dal sito NVIDIA l’ultimo driver per la mia scheda (NVIDIA-Linux-x86-180.29-pkg1.run), seguo le indicazioni della guida (forse sbaglianod, perché ho riatto tutta la procedura, non sono partito solo dal punto 5: ho ricontrollato che le varie modifiche dal p1 al p4 ci fossero ancora), e xserver non parte.
    Ripeto la procedura, e non funziona di nuovo.
    Noto, nel caricamento del kernel, che i moduli NVIDIA caricati sono i 177.82…?
    Vado allora a cercare nel forum e nell’help della NVIDIA e, tra le altre cose, provo a disinstallare i linux-restricted-modules.
    Totale:
    1) il pc è più lento
    2) la grafica è, naturalmente, peggiore e non posso attivare alcun effetto grafico
    3) non funziona più correttamente la gestione alimentazione: se metto il pc in sospensione, poi non riparte più
    4) vari sw (mi è capitato con ARK) non funzionano, e ho dovuto reinstallarli.

    ho reinstallato i restricted…

    Poi ho trovato la seguente guida “http://forum.ubuntu-it.org/index.php/topic,72244.0.html”, e, anche se non è per 8.10, ho provato a seguirla. Ho installato il driver 180.11 (sudo apt-get install nvidia-glx-180 (180.11-0ubuntu1~intrepid1)), e almeno all’apparenza si sono caricati i moduli 180.11. poi, però, al riavvio tenta di caricare i driver, infatti appare 3 volte il logo NVIDIA, ma si blocca xserver, e ho dovuto ripristinare i drivers standard.

    Avete qualche idea, qualche consiglio, qualche soluzione?

    Aggiungo che sul sistema c’è regolarmente installato “NVIDIA XServer Setting”; se provo ad utilizzarlo che mi dice:
    “You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.”

    Se lancio quel comando, poi xserver non riparte…

    Commento di mauro — marzo 5, 2009 @ 10:47 pm

  170. Dimenticavo di dire che ho un notebook HP Pavillon dv6000 con scheda video NVIDIA GeForce Go 7400.

    Commento di mauro — marzo 5, 2009 @ 10:48 pm

  171. @mauro
    gli aggiornamenti kernel di ubuntu sono “perennemente” un disastro nucleare, se il pc funziona, disattivate una volta per tutti sti cavolo di aggiornamenti, fateli solo se avete problemi gravi con qualche periferica o se siete “esperti” a gestire i potenziali casini.
    Altrimenti ti ritrovi in queste situazioni.
    Non puoi ripartire da grub con un kernel precedente e reinstallare i driver dopo aver rimosso tutti i cavoli di moduli nvidia di Ubuntu come descrtitto in TUTTI passi?
    O usi quelli o usi il file .run, non si può far casini e mischiare tutto.
    La guida funziona perfettamente anche con Ubuntu 9.04, testata.

    Commento di telperion — marzo 5, 2009 @ 11:23 pm

  172. OK.

    Cosa mi consigli di fare? Recuperare un kernel precedente o passare alla 9.04?
    Nel primo caso mi spiegheresti meglio che fare? (Non puoi ripartire da grub con un kernel precedente e reinstallare i driver dopo aver rimosso tutti i cavoli di moduli nvidia di Ubuntu come descrtitto in TUTTI passi?)…

    grazie

    Commento di mauro — marzo 5, 2009 @ 11:49 pm

  173. @mauro
    quando parte il grub premi ESC
    dovresti avere tra le voci il kernel precedente, selezionalo e parti con quello.

    Commento di telperion — marzo 5, 2009 @ 11:54 pm

  174. Quindi non mi consigli di passare alla 9.04?

    Commento di mauro — marzo 6, 2009 @ 8:26 am

  175. Ho provato a avviare con il kernel precedente, poi ad eseguire la reinstallazione del driver nvidia, ma xserver si blocca esattamente come prima.
    Non è che questa versione del driver nvidia ha dei proiblemi?

    Commento di mauro — marzo 6, 2009 @ 9:29 am

  176. Allora: ho disinstallato la 180.29 (–uninstall) ma la versione precedente (177.70.33) non riesce ad installarsi.
    Ho reinstallato la 180.29 e siamo punto a capo… sia con il kernel 12, il precedente, che con il 13, che in questo momento sto utilizzando…
    Che posso fare?
    Mi conviene reinstallare ubuntu?

    Commento di mauro — marzo 6, 2009 @ 10:00 am

  177. Penso di avere risolto: alla fine ho deciso di disinstallare tutti i gestori video e i componenti xserver che non fossero quelli puramente generici, quindi tutto ciò che riguarda nvidia, ati ecc…
    Dopo ho provato a reinstallare i nuovi driver nvidia, operazione che mi ha restituito molteplici errori di files e cartelle mancanti, che penso siano stati ricostruiti dall’installer, e ora funziona di nuovo tutto, almeno così sembra.
    Speriamo bene…

    Grazie comunque dell’aiuto

    Commento di mauro — marzo 6, 2009 @ 5:15 pm

  178. @mauro
    Come vedi non sei l’unico ad avere problemi con quel kernel

    http://forum.ubuntu-it.org/index.php?PHPSESSID=3bcf6c17663717828e4eb579e1ae1dcc&topic=267563.msg1907129;topicseen#msg1907129

    Consiglio di lasciare attivi solo gli “aggiornamenti di sicurezza” su Ubuntu e disattivare tutti gli altri.

    Commento di telperion — marzo 7, 2009 @ 10:36 am

  179. […] volete installarli potete seguire l’ottima guida di telperion (leggermente datata, ma comunque valida). Verificate la compatibilità dei driver con […]

    Pingback di Nuovi driver Nvidia 180.44: sistemati alcuni crash con Plasma — marzo 31, 2009 @ 6:27 pm

  180. ciao a tutti..complimenti per l’ottima guida!solo che mi è capitato un “problemino”..ogni volta che cerco installare i driver grafici con sh NVIDIA….180.44.sh alla fine m compare una scritta dicendomi:
    ERROR: The runtime configuration check failed for the library
    ‘libnvidia-tls.so.180.44’ (expected:
    ‘/usr/lib/tls/libnvidia-tls.so.1’, found:
    ‘/usr/lib/libnvidia-tls.so.1’). The most likely reason for this is
    that conflicting OpenGL libraries are installed in a location not
    inspected by `nvidia-installer`. Please be sure you have uninstalled
    any third-party OpenGL and/or third-party graphics driver packages.
    Sto impazzendo!Grazie per l’attenzione…

    Commento di skyy — aprile 5, 2009 @ 4:09 am

  181. @skyy
    /usr/lib/tls/libnvidia-tls.so.1
    è in una cartella installata da qualceh pacchetto che interferisce.
    Rimuovi il pacchetto che ha installato quei file, o se non ne vieni a capo
    cancella i file che trovi col comando

    find /usr/lib -iname libnvidia-tls*

    poi installa il driver.

    Commento di telperion — aprile 5, 2009 @ 9:48 pm

  182. grazie 1000 telperion per la tempestiva risposta,ho fatto come tu m dicevi e con
    find /usr/lib -iname libnvidia-tls* trovavo le librerie “libnvidia-tls.so.1” e “libnvidia-tls.so.180.44” in /usr/lib e in /usr/lib/tls/ ,entrambe in entrambe le cartelle.le eliminate e reinstallate ma il problema rimane identico…

    Commento di skyy — aprile 5, 2009 @ 10:41 pm

  183. @skyy
    allora forse il driver ha qualche bug con la tua distribuzione.
    Usa il 180.41 e vedi se funziona, se si installa correttamente allora forse il 180.44 ha qualche problema con l’installazione sulla tua distro. Boh.

    Commento di telperion — aprile 5, 2009 @ 11:32 pm

  184. ciao teleperion..nemmeno così sono riuscito a sistemare! però sono riuscito a mettere apposto tutto…da quanto ho capito l’installer dell’nvidia ha 2 modi di compilare le libnvidia-tls in base a se usi le glib = 2.3.detto questo ho praticamente forzato l’installazione con l’opzione –force-tls=FORCE-TLS, e al posto di FORCE-TLS ho usato “classic” (per le librerie glib 2.2).
    per chi avesse lo stesso problema l’altra opzione è usare –force-tls=”new” per le librerie glib >= 2.3.
    Tutto questo l’ho trovato nell’helper di nvidia-installer con il comando “sh NVIDIA-Linux-x86…..run -A ”
    Grazie lo stesso ora ho capito il problema!

    Commento di skyy — aprile 6, 2009 @ 3:11 pm

  185. Salve a tutti…ho un problema che mi sta facendo impazzire! Ho ubuntu 9.04 e dopo aver scaricato dei nuovi giochi e screenlets e cazzate varie usando un rooter,ho spento e riacceso..e dopo che la linea carica…NERO TOTALE!Neanche il log in o la musichetta del log in .. niente..solo tutto nero!Dopo che la linea di ubuntu carica,lo schermo appare e scompare ad intermittenza x 2,3 volte..e poi NERO!!! Perfavore qualcuno mi dia una mano… nella mia ignoranza credo di aver scaricato qualcosa che abbia fatto contrasto con qualche altra cosa…non so.. ma please,aiutatemi.
    Il mio indirizzo email e’ carletto1981@gmail.com.

    Commento di Carlo — giugno 9, 2009 @ 2:59 pm

  186. Telperion la guida è una eccezionale, a prova di noob. Installati e funzionanti alla perfezione. Ora mi sto mettendo di impegno con VDPAU quindi è questione di ore e poi incasinerò tutto quanto di nuovo…..
    grazie e ciao.

    Commento di southwave — giugno 27, 2009 @ 7:43 pm

  187. ciao grazie mille e complimenti per la guida…purtroppo ho un problema che mi pare assurdo:

    ho seguito tutta la procedura senza problemi fino a metà del punto 5), dopodichè ho fatto partire sudo nano -w-/etc/X11/xorg.conf e…nulla!
    in pratica mi la schermata di configurazione ma non c’era nessuna riga di parametro…nulla!

    Section “Device”
    Identifier “Configured Video Device”
    EndSection

    Section “Monitor”
    Identifier “Configured Monitor”
    EndSection

    Section “Screen”
    Identifier “Default Screen”
    Monitor “Configured Monitor”
    Device “Configured Video Device”
    EndSection

    …ergo, non trovando nessuna riga da modificare, non so più come andare avanti…eppure reputo improbabile che le impostazioni di xorg si tengano su con la magia 😛

    quale può essere il problema? Premetto che ho un nvidia n6 Vanta/Vanta LT e ho installato la versione x71 dei driver…

    grazie mille in anticipo

    Commento di underdark — luglio 23, 2009 @ 7:17 pm

    • Potevi farlo modificare all’installer come detto.
      Ora puoi fare
      sudo nvidia-xconfig

      Commento di telperion — luglio 23, 2009 @ 7:46 pm

  188. eh…ma l’installer all’inizio non mi ha chiesto se volevo modificarlo in automatico, ma mi ha solo “avvertito” che andava modificato, di leggermi la guida e di arrangiarmi…<.<

    grazie, ora provo

    Commento di underdark — luglio 24, 2009 @ 10:09 am

  189. ho provato col comando

    sudo nvidia-xconfig

    ma ottengo questa risposta:

    sudo: nvidia-xconfig: command not found

    Commento di underdark — luglio 24, 2009 @ 10:29 am

    • Forse perchè hai i driver 71 magari non c’è.
      Scheda molto vecchia prova ad aggiungere

      Driver "nvidia"

      alla sezione device dopo
      Identifier “Configured Video Device”

      Se non va meglio che chiedi aiuto in un forum, oppure usa i driver foss di xorg, tanto la tua scheda ha quasi nulle capacità di accelerazione, essendo troppo antica.

      Commento di telperion — luglio 24, 2009 @ 11:21 am

  190. troppo preistorica in effetti, ci sta che rinunci….non volevo lasciare nulla di intentato ^_^
    grazie mille comunque!

    Commento di underdark — luglio 24, 2009 @ 11:30 am

  191. Complimenti per la guida: estremamente chiara e davvero utilissima! ^_^

    Ho appena aggiornato Debian Squeeze al kernel 2.6.30-1-686 dal 2.6.26-2-686 e quelli nei repository non-free non funzionavano più.

    Grazie mille!

    Commento di HAL 9000 — agosto 16, 2009 @ 1:10 pm

  192. […] in pratica fa da solo e poi non serve reinstallarli a ogni nuovo kernel, e l’altro consiste nell’installarli manualmente, con lo svantaggio che a ogni nuovo kernerl bisogna […]

    Pingback di Debian Squeeze: esperienze di un installazione (e qualche consiglio per chi la vuole provare) « Ubuntu Experiments — settembre 27, 2009 @ 10:46 am

  193. ciao ho seguito dettagliatamente la tua guida e ho installato cn successo il driver 180.60 per la mia 8600gt su jaunty.
    l’unico problema è che non riesco a patchare il driver per il kernel rt.
    il risultato è questo:

    Verifying archive integrity… OK
    Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 180.60………….
    patching file usr/src/nv/nv-linux.h
    Reversed (or previously applied) patch detected! Assume -R? [n]
    Apply anyway? [n]
    Skipping patch.
    1 out of 1 hunk ignored — saving rejects to file usr/src/nv/nv-linux.h.rej
    patching file usr/src/nv/os-interface.c
    Reversed (or previously applied) patch detected! Assume -R? [n]
    Apply anyway? [n]
    Skipping patch.
    1 out of 1 hunk ignored — saving rejects to file usr/src/nv/os-interface.c.rej
    Failed to apply patch file “/home/Iago/Scrivania/NVIDIA_kernel-173.14.09-2512683.diff.txt”.

    sembrerebbe che questo driver sia già patchato ma allora perchè non gira sul kernel RT (2.26.28-3)?

    Commento di Iago — ottobre 1, 2009 @ 9:27 am

  194. telperion ha scritto:
    “No so che scheda Nvidia ho e che driver installare
    installate hwinfo
    hwinfo –gfxcard | grep Device: ”

    Premesso che so quale scheda video ho, però ho voluto provare, anche perchè ho qualche problemino al logout (strisce bluette e verdi per 3/4 di schermo).
    La mia scheda video è una GeForce GT 220.
    Col comando di hwinfo, ottengo:
    Device: pci 0x0a20
    SubDevice: pci 0x8311
    E al sito http://us.download.nvidia.com/XFree86/Linux-x86/180.06/README/appendix-a.html, cercando 0x0a20 non trovo nulla
    Inoltre esaminando /var/log/Xorg.0.log, trovo:
    (–) PCI:*(0@1:0:0) nVidia Corporation unknown chipset (0x0a20) rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x0000c800/128, BIOS @ 0x????????/524288
    Che significa “unknown chipset”? E’ troppo recente la scheda grafica o c’è qualche errore di riconoscimento?
    Ho installato i driver 195.36.15 sia tramite repository, che con il metodo qui descritto. L’installazione va a buon fine e vedo tutto perfettamente.
    Rimane il problema che al logout o a un riavvio vedo quelle brutte strisce di cui non so se preoccuparmi.
    Prima d’installare jaunty su hdd, avevo provato da live a installare i driver e non avevo rilevato alcun problema.
    Il monitor è CRT, risoluzione 1024×768, frequenza 85 MHz.
    Hai una vaga idea del perchè di tutto ciò?

    Commento di ivy — marzo 29, 2010 @ 5:29 pm

    • La gt220 0x0A20 è riconosciuta perfettamente dai driver 195.36.15 attualmente gli stabili ufficiali.

      ftp://download.nvidia.com/XFree86/Linux-x86/195.36.15/README/supportedchips.html

      GeForce GT 220 0x0A20 C

      Commento di telperion — marzo 30, 2010 @ 12:46 pm

      • Sì, a quel link la vedo pure io. OK.
        Strano però quell’effetto sul monitor all’arresto del server X.
        Vorrei sapere soltanto se me ne devo preoccupare.
        Ti ringrazio cmq. 🙂
        PS: la tua guida è la migliore che abbia trovato in tutto il web. Altro che wiki! 😉

        Commento di ivy — marzo 30, 2010 @ 6:37 pm

      • “Strano però quell’effetto sul monitor all’arresto del server X.”

        Niente di preoccupante.

        Commento di telperion — marzo 30, 2010 @ 9:17 pm

  195. Non ci sono parole, adoro questa guida, mi ha salvato da un abisso di disperazione (stavo seguento il wiki ufficiale e non era il massimo della chiarezza, per chi come me, prova Debian Lenny per la prima volta).

    L’unica parte che mi ha dato qualche preoccupazione è il punto in cui all’avvio dell’installazione del driver mi dava questo messaggio:
    “The compiler used to compile the kernel (gcc 4.1) does not exactly match the current compiler (gcc 4.3). The Linux 2.6 kernel module loader rejects kernel modules built with a version of gcc that does not exactly match that of the compiler used to build the running kernel.
    If you know what you are doing and want to ignore the gcc version check, select “No” to continue installation. Otherwise, select “Yes” to abort installation, set the CC environment variable to the name of the compiler used to compile your kernel, and restart installation. Abort now? (Answer: No)”

    Ho schiacciato No, e tutto è filato liscio, però qui http://forums.debian.net/viewtopic.php?t=35845 danno questo consiglio:

    Check to make sure that you have gcc-4.1 installed. (It can co-exist with gcc-4.3, which is the most recent). What happens is that the current kernel in your sustem was compiled with a 4.1 version of the compiler. The default version on your system is 4.3. The compiler versions have to match when compiling kernel modules.

    To correct this first, as I said, make sure you have gcc-4.1 installed. Then alter the way you start the Nvidia installer as follows:

    # env CC=gcc-4.1 ./NVIDIA-Linux-

    That will alter the compiler used for just that one run without actually changing the default.

    Commento di Vale — aprile 29, 2010 @ 2:17 am

    • é solo un avviso, gcc 4.1 4.2 e 4.3 sono perfettamente compatibili, puoi ignorare il messaggio e continuare la compilazione senza problemi.

      Commento di telperion — aprile 30, 2010 @ 1:40 am

  196. Perdonami ma non riesco a capire come fare per scaricare i driver. Appena li cerco sul sito per la mia scheda nvidia G105M mi esce una pagina piena di comandi ma nessuna traccia del file run… 😦

    Commento di Antonello — aprile 29, 2010 @ 11:27 am

    • Con firefox tasto destro sul link, “salva destinazione con nome …”, è un problema di firefox che pensa siano file di testo.

      Commento di telperion — aprile 30, 2010 @ 1:42 am

  197. quele driver scelgo per una nvidia geforce 4 mx 440?

    Commento di pciuggo — giugno 15, 2010 @ 5:00 pm

    • vedi:
      No so che scheda Nvidia ho e che driver installare

      Occhio che la guida non è aggiornata per Lucid quindi bisogna “aggiustarsi” con i blacklist dei nouveau e boiate varie se si è toccato il plymouth del cavolo.

      Commento di telperion — giugno 15, 2010 @ 7:14 pm

  198. Ti ringrazio di cuore per questa tua guida! Finalmente sono riuscito a sistemare la mia 9.10 di ubuntu con la mia Nvidia!

    Che INVIDIA CHE MI FAI!!!

    CON AFFETTO,

    TONIO CASU

    Commento di zenobio — marzo 29, 2011 @ 9:42 pm

  199. C’è qualche speranza che quest’ottimo articolo venga aggiornato per le ultime versioni di Ubuntu?

    Commento di Emanuele — maggio 25, 2012 @ 3:33 pm

    • sostanzialmente non cambia molto, devi solo killare e far ripartire invece del gdm, il manager in uso gdm3 lightdm eccetera.
      Poi possono esserci problemi con i nouveau e bisogna blacklistare i moduli, anche con plymouth possono nascere casini.
      Ubuntu non la uso più da 3 anni, non saprei con precisione, so che ci sono dei ppa con gli ultimi driver nvidia sempre aggiornati, ci sono anche guide aggiornate per i driver .run cerca con Google.

      Commento di telperion — maggio 25, 2012 @ 4:01 pm

      • Grazie per la risposta e per le indicazioni. Avrei voluto seguire la tua guida perché è più completa di quelle che si trovano generalmente in rete. Visto che ormai non è più “testata su strada”, preferisco usare direttamente il jockey integrato in ubuntu, sperando di essere comunque in grado di poter tornare indietro se dovessi attivare una versione dei driver non buona per il mio modello di scheda video…

        Commento di Emanuele — maggio 28, 2012 @ 9:48 am


RSS feed for comments on this post.

%d blogger hanno fatto clic su Mi Piace per questo: