Tecnologia e non solo

aprile 20, 2007

Sid: aggiornamenti Xorg 20 aprile – soluzione (finale)!

Filed under: Beryl,Debian,Sid — telperion @ 12:48 pm

Attenzione agli aggiornamenti Xorg di oggi (20 aprile):

Con quelli di Xorg (gli ulitimi 4 della lista) ricompilando correttamente il driver Nvidia dal file .bin
(operazione che avviene senza alcun intoppo), il modulo Nvidia non viene rilevato
in alcun modo al riavvio e quindi funziona solo con il modulo “nv”.

Ripristinati alla versione precedente quei 7 pacchetti, con la rimozione forzata di uno nuovo
sudo dpkg -r --force-all xserver-xorg-video-intel
e ricompilando il driver Nvidia, tutto torna a funzionare regolarmente.

Prestate massima attenzione.
Se avete maggiori info sui problemi descritti postate i link alle discussioni/news.
Grazie.

Aggiornamento:
dopo uno scambio di post con Imu, che ringrazio, vedi link nel commento sotto,
mi lancio in un’ipotesi.
Non ricompilando il driver Nvidia 9755 dal .bin, ma solo ripristinando i link simbolici,
interrotti come sempre dall’installazione xorg-core, come da guide di Imu, tutto funziona.
Solo che siamo nella non ottimale condizione di non poter ricompilare il driver Nvidia,
forse perchè Xorg è il 7.3?
Aspettiamo aggiornamento driver Nvidia con supporto al 7.3?
Una patch all’installer o altro?
Manca qualche -dev aggiornato?

Ai “posters” l’ardua sentenza. (Nel fattempo metto da parte i deb per il downgrade).

Aggiornamento 2 e SOLUZIONE! (parziale)

Non abbiamo dovuto aspettare molto:

Ecco i nuovi driver Nvidia 100.14.03 perfettamente compatibili con xorg 7.3.
Un plauso a Nvidia per la rapidità oltre che alla tradizionale bontà dei loro driver.

Aggiornamento 3 e SOLUZIONE! (migliore)

Grazie ad imu, visti problemi del nuovo driver con le consolle (a me si spegne l’LCD)
è decisamente meglio compilare il 9755 con le seguenti opzioni:

sudo sh NVIDIA-Linux-x86-1.0-9755-pkg1.run -a -n -N --x-module-path=/usr/lib/xorg/modules

Altre info nel post dell’autore.
Ancora grazie ad imu che si “sbatte” e condivide le soluzioni.

Annunci

14 commenti

  1. Per nvidia senza reinstallare il .bin si risolve così :
    Nvidia da installer su Debian/Ubuntu – upgrade xserver-xorg-core
    Nvidia da installer su Debian/Ubuntu – upgrade libgl1-mesa-glx
    Per gli altri non saprei 😉

    Commento di imu — aprile 20, 2007 @ 2:27 pm

  2. Se ne parla anche quà
    http://osrevolution.wordpress.com/2007/04/15/tanto-per-tenervi-aggiornati-su-debian-sid/

    Commento di telperion — aprile 20, 2007 @ 3:13 pm

  3. @telperion
    volevo tenerti aggiornato, ho appena compilato il driver nvidia e tutto è andato per il verso giusto, non ho riscontrato nessun problema .

    Commento di imu — aprile 21, 2007 @ 10:56 am

  4. @telperion
    Scusa non avevo visto l’aggiornamento 🙂 LOL ok ho compilato il nuovo anch’io forse è per quello . Ciao

    Commento di imu — aprile 21, 2007 @ 10:58 am

  5. si imu il vecchio 9755 non si compila, mentre il nuovo è ok.

    Commento di telperion — aprile 21, 2007 @ 11:01 am

  6. Nota: soluzione per chi usa i driver Nvidia, per Ati non ho la minima idea di come si possa procedere.

    Commento di telperion — aprile 21, 2007 @ 12:36 pm

  7. Una curiosità: Xorg 7.3 te lo sei ricompilato oppure su debian sid lo aggiornano prima che su ubuntu?

    Commento di thewall83 — aprile 22, 2007 @ 12:16 pm

  8. […] con schede video nvidia , che usano i driver closed stanno avendo disdicevoli problemi . Ieri avevamo risolto con i driver beta ma oggi si è presentato un altro problema , cambiano console con Crtl + […]

    Pingback di Debian SID upgrade xserver-xorg e solito nvidia installer - soluzione ! « O.S. Revolution — aprile 22, 2007 @ 4:57 pm

  9. @thewall: non sono sicuro che sia il 7.3 (ma credo di si), è una mia speculazione
    da come è numerato e anche dalla versione di libxrandr, non suffragata da alcunchè di ufficiale.
    Arriva da debian, come del resto quasi tutto quello che trovi su Ubuntu.
    O credi che lo porta babbo natale? 🙂

    Commento di telperion — aprile 22, 2007 @ 6:20 pm

  10. lol.

    Commento di Cristian75 — maggio 3, 2007 @ 2:59 pm

  11. […] Niente paura stà arrivando gnome 2.18 ed il nuovo xorg (vedi per conoscenza questo post di Sid). […]

    Pingback di Debian Lenny (testing) problemi Beryl « Tecnologia e non solo — giugno 5, 2007 @ 3:51 pm

  12. Sapete se è ancora necessario specificare il path, alla data odierna?
    --x-module-path=/usr/lib/xorg/modules
    Inoltre in caso di disinstallazione (per es. aggiornamento di xorg su un ramo non stabile), bisogna specificarlo di nuovo, o l'installer lo cerca da solo?

    Commento di notoriousxl — settembre 11, 2007 @ 9:24 pm

  13. @notoriousxl: no non serve più con i driver 100.14.11,
    se usi i 9755 penso di si invece

    Commento di telperion — settembre 11, 2007 @ 11:08 pm

  14. @telperion
    Grazie 😉

    Commento di notoriousxl — settembre 11, 2007 @ 11:40 pm


RSS feed for comments on this post.

%d blogger hanno fatto clic su Mi Piace per questo: