Tecnologia e non solo

novembre 12, 2007

BERYL – Pacchetti deb i386 Ubuntu Kubuntu Gutsy

Archiviato in: Beryl,Gutsy,Pacchetti — telperion @ 12:53 am

Post originale del 3 agosto 2007 

BERYL Git + heliodor + aquamarine + kiba-dock Telperion edition

Pacchetti deb i386 per Ubuntu Gutsy
*aggiunti i pacchetti emerald corretti con patch resize (vedi commento 21).

Beryl 0.3.0 Git Gutsy Gibbon

Beryl 0.3.0 Git

Alcuni parametri di default sono stati ottimizzati,
potete installarla e non settare nulla se volete.

beryl-0.3-git-gutsy-0813-telperion.tar.gz (5.81 MB) del 13 agosto
mirror rapishare

Beryl add-on – Extra-Artwork

Questa è una versione collaudata e funzionante.

Scompattate il file tar.gz
(su gnome tasto destro estrai qui)
poi nella cartella beryl-0.3-git-gutsy-xxxx-telperion da terminale:

sh beryl-svn.sh

e seguite le istruzioni (consigliato)
che vi consente di installare solo i pacchetti che vi servono
e di ottenere un’installazione sicura
dato che prima rimuove pacchetti esistenti,
e ha anche una funzione di rimozione di beryl,
senza dover usare synaptic/adept

echo “1) Install Beryl”
echo “2) Install Beryl and Heliodor (GNOME)”
echo “3) Install Beryl and Aquamarine (KDE)”
echo “4) Remove Beryl”
echo “5) Quit.”
echo -n “Your choice(1,2,3,4,5 better is 2 for Gnome, 3 for Kde): “

Al termine dell’installazione risolvete dipendenze mancanti
e/o eventuali pacchetti non configurati con il consueto

sudo apt-get install -f

—————————————————
nella cartella gnome-kiba-dock
kiba-dock per Gutsy Gibbon
è la prima versione quella solo con
il laucher della applicazioni.
—————————————————

Se volete rimuovere questi pacchetti
da synaptic/adept rimuovete tutti i pacchetti
beryl emerald heliodor
o usate il comando (nella cartella decompressa)

sh beryl-svn.sh

e scegliete remove beryl

—————————————————

Nota:
Consiglio prima di installare di rimuovere completamente con
synaptic o adept
usando la funzione “cerca” tutti i pacchetti
beryl emerald heliodor aquamarine compiz fusion
che avete nel sistema.
Setting e temi personali non saranno toccati dalla disinstallazione,
vanno cancellati (se si vuole) a mano nelle cartelle nascoste
.beryl .emerald
nella home


Free Image Hosting at www.ImageShack.us

—————————————————
—————————————————

Note tecniche, per compilare da sorgenti Git.
Patch applicate per la compilazione su Gutsy Gibbon:

trunk/emerald/configure.ac
45a46,53
> PKG_CHECK_EXISTS(libwnck-1.0 >= 2.19.3,
> [have_libwnck_2_19_3=yes], [have_libwnck_2_19_3=no])
>
> if test "$have_libwnck_2_19_3" = yes; then
> AC_DEFINE(HAVE_LIBWNCK_2_19_3, 1,
> [Define to 1 if libwnck version >= 2_19_3])
> fi
>

trunk/emerald/src/main.c
3872a3873
> #ifndef HAVE_LIBWNCK_2_19_3
3873a3875
> #endif

trunk/heliodor/configure.ac
39a40,47
> PKG_CHECK_EXISTS(libwnck-1.0 >= 2.19.3,
> [have_libwnck_2_19_3=yes], [have_libwnck_2_19_3=no])
>
> if test "$have_libwnck_2_19_3" = yes; then
> AC_DEFINE(HAVE_LIBWNCK_2_19_3, 1,
> [Define to 1 if libwnck version >= 2_19_3])
> fi
>

trunk/heliodor/src/main.c
3340a3341
> #ifndef HAVE_LIBWNCK_2_19_3
3341a3343
> #endif

About these ads

53 commenti

  1. [...] BERYL – Pacchetti deb i386 Ubuntu Kubuntu Gutsy Gibbon – 0.3.0 Git Telperion edition [...]

    Pingback di E Beryl? « Tecnologia e non solo — agosto 4, 2007 @ 12:00 am

  2. Ciao Telperion, volevo porti una domanda:
    Uso Kubuntu Feisty 7.04
    Che differenza c’e’ tra i pacchetti beryl-0.3-git-gutsy-0803-telperion.tar.gz e beryl-git-20070501-feisty-telperion.tar.gz ?
    Uso uso con grande soddisfazione la vecchia versione ( grazie per il lavoro che hai fatto!!!) e va tutto alla grande anche con la mia sfigatissima ATI XPRESS 200M.
    Il nuovo pacchetto è solo per chi installa Gusty o magari ci sono nuovi plug-in inseriti (del tipo riflessi alla compiz-fusion)?
    Prima di installare la nuova versione dovrei rimuovere il vecchi pacchetto?
    Grazie ci sentiamo ciao

    Torrazzi

    Commento di torrazzi — agosto 5, 2007 @ 11:37 am

  3. @Torrazzi:
    No i pacchetti per Gutsy sono gli stessi di Feisty compilati per funzionare sulla Gutsy Gibbon.

    Non c’è nessun plugin nuovo (ne credo mai ci saranno),
    è sempre il git 0.3.0, l’ultimo sviluppato prima dello stop.

    Il pacchetto è per chi usa Gutsy
    e vuole continuare ad usare Beryl.

    Commento di telperion — agosto 5, 2007 @ 12:01 pm

  4. Grazie Telperion per la tua solerte risposta.
    Anche se c’e’ Compiz-Fusion continuero’ ad usare con GRANDE soddisfazione Beryl-Git 0.3.0!!!
    :-)))))))))))))))))

    Ciaooooooooooooo

    Torrazzi

    Commento di torrazzi — agosto 5, 2007 @ 12:15 pm

  5. Google EARTH si scrive, cmq grazie mille per i pacchetti, mi servivano proprio! ;)

    Commento di Piplos — agosto 6, 2007 @ 1:08 pm

  6. @Piplos: lol hai ragione, cosi è “core de google”.

    Commento di telperion — agosto 6, 2007 @ 1:45 pm

  7. Ciao,intanto complimenti e grazie per questi fantastici pacchetti.
    Volevo sapere.
    Ho una ATI 9550 :(.
    Ho seguito le istruzioni di questa guida e ho scelto (“2) in fase di installazione.
    Ps:ho xgl.
    IL problema è che se anche parte beryl-manager,quando seleziono come gestore di finetre “beryl”, fa’ 2-3 refhresh dello schermo e poi mi ritorna Metacity,uso Ubuntu 7,come posso risolvere il problema?
    Grazie.

    Commento di Jacopo — agosto 27, 2007 @ 3:14 pm

  8. @Jacopo leggi:
    http://divilinux.wordpress.com/2007/06/07/installazione-fglrx-837-kubuntu-feisty/

    Solo la parte

    =============
    Da evitare…
    =============

    4-Ricordarsi sempre le due opzioni fondamentali,da aggiungere al file xorg.conf,per le schede ATI+FGLRX

    Di più non so che dirti visto che ho una Nvidia.
    Comunque se hai problemi il forum è il posto giusto dove chiedere.

    Inoltre questi sono i pacchetti per Gutsy (7.10)
    Se usi la Feisty (7.04) devi scaricare quelli per feisty appunto.

    http://telperion.wordpress.com/2007/04/30/beryl-030-git-per-feisty-telperion-edition/

    Commento di telperion — agosto 27, 2007 @ 5:06 pm

  9. Ciao Telperion, ero un felice utente di beryl 0.21 preso dai repo della 7.04 (io uso kubuntu), poichè i 0.3.0 non ufficiali (sia i tuoi che quelli di trevino) crashavano inspiegabilmente quando aprivo alcune finestre… ti è mai capitato di sentire una cosa del genere? hai qualche soluzione?
    E se magari volessi compilarlo da me beryl 0.3? dove recupero i sorgenti sul sito di beryl ci sono solo i 0.21.

    Commento di Algol — ottobre 22, 2007 @ 7:51 pm

  10. Ciao telperion,
    ho installato i tuoi deb su kubuntu gutsy (compiz-fusion con kde mi dà ancora problemi…), ma mi capita un problema strano. Con emerald non posso rimpicciolire una finestra dai bordi di destra e da quello in basso, cosa che invece posso fare dai bordi di sinistra e da quello in alto. La cosa strana è che proprio non mi appare la solita freccia che mi permette il resize. Sai a cosa può essere dovuto? ti è capitato? ho visto che kde-windows-decorator questo non succede, ma sinceramente trovo emerald molto più stabile.

    Ti ringrazio
    ciao

    Commento di Scido — novembre 3, 2007 @ 3:53 pm

  11. ciao senti io ho provato a scaricare il pacchetto ma sfortunatamente mi dice che non è disponibile…

    Commento di f4b10 — novembre 4, 2007 @ 3:59 am

  12. Ciao uso kubuntu gutsy gibbon ho scaricato i file installato tutto e va a la grande ma solo finche riavvio il pc. dopodiche beryl non va piu se provo a caricare beryl manager ci pensa un po e poi semplicemente non fa nulla. Hai qualce spiegazione? ho provato a disinstallare e reinstallare beryl sia col programma scaricato che controllando tutti i pacchetti con adept ma nulla, funziona solo appena installato una volta riavviato non va piu!!!

    Grazie

    Commento di ebola — novembre 5, 2007 @ 1:22 am

  13. @ebola
    su kde per qualche strano motivo quando fà così
    devi chiudere il beryl-manager
    cancellare la cartella nascosta nella home
    ~./beryl
    ed il file nascosto nella home
    ~/.beryl-managerrc

    poi riavvia il beryl-manager
    e scegli beryl poi di solito funziona e non rompe più.
    Perchè? Boh!

    Commento di telperion — novembre 5, 2007 @ 1:30 am

  14. grazie mille adesso va, ma questo procedimento mi tocca farlo ad ogni riavvio!!!!…un altro problema è che le finestre si possono ridimensionare solo dal bordo sinistro e superiore e non dagli altri due come mai?

    Commento di ebola — novembre 6, 2007 @ 12:12 am

  15. @ebola:
    ad ogni riavvio non è normale. Prova ad usare Emerald e non usare Aquamarine che non è mai stato troppo stabile.
    Se ti da tutti quei problemi
    (a me funziona con scheda video nvidia,
    sia con gnome che con kde senza particolari problemi su gutsy)
    allora passa a Compiz/Fusion.

    Commento di telperion — novembre 6, 2007 @ 12:39 am

  16. sono passato a ubuntu on compiz fussion e va una bellezza…grazie cominque!

    Commento di ebola — novembre 6, 2007 @ 10:23 pm

  17. Tento di scaricare Beryl 0.3.0 GIT ma esce un errore:

    “Invalid Quickkey. This error has been forwarded to MediaFire’s development team.

    The quickkey you provided for file download was invalid. This is usually caused because the file is no longer stored on Mediafire. This occurs when the file is removed by the originating user or Mediafire.”

    Come faccio??

    Commento di Gianfrix — novembre 7, 2007 @ 2:18 pm

  18. E’ la seconda volta che mediafire “perde” il file.
    Aggiunto anche un mirror rapidshare.

    Commento di telperion — novembre 7, 2007 @ 5:23 pm

  19. Grazie!!!! Ora scarica tutto!!!!

    Commento di Gianfrix — novembre 7, 2007 @ 6:53 pm

  20. Ciao,
    ho visto che anche altre persone hanno avuto lo stesso problema del resize, impossibile dai lati destro e inferiore. Ho scoperto che ciò è dovuto alle librerie libwnck22, ossia la versione presente in gutsy (ho compilato i pacchetti di beryl 0.21 dai rep di feisty usando le vecchie librerie libwnck18 e tutto funziona alla perfezione). Mi sembra strano che nessuno, ovviamente su gutsy, non abbia questo problema. La cosa migliore sarebbe ricompilare beryl 0.3 usando le libwnck18.

    Info da: http://bugs.archlinux.org/task/8328

    ciao

    Commento di Scido — novembre 11, 2007 @ 9:02 pm

  21. @scido
    io nel mio sistema ho questi pacchetti e libwnck22 2.20.1-0ubuntu1
    ed il resize di emerald ed heliodor funziona perfettamente sui 4 lati.

    Questa patch http://tinyurl.com/2cw4zl
    è stata applicata, altrimenti emerald non compila.

    Ad esempio un problema noto è che con le ultime versioni di Wine
    i decoratori emerald e heliodor non vanno, quindi avrete applicazioni wine senza bordi finestre.

    AGGIORNAMENTO:
    avete ragione voi, causa confusione,
    io ho i pacchetti emerald patchati 20070813 ma non li ho messi nell’archivio.
    Aggiorno subito – scusate.

    Le versioni 64 bit e sid invece sono a posto.

    Commento di telperion — novembre 11, 2007 @ 11:17 pm

  22. Grande!!!!

    grazie mille. Lì proverò appena tornerò a casa…
    domi

    Commento di scido — novembre 12, 2007 @ 12:20 pm

  23. TELPI….A dir poco magnifico…..

    Commento di UTONTO — novembre 13, 2007 @ 8:03 pm

  24. visto che ho un sistema a 64bit e non posso usare i tuoi .deb
    potresti scrivere le istruzioni per scaricare e compilarsi da se’ il tutto?
    grazie

    Commento di Maurizio — novembre 14, 2007 @ 8:35 am

  25. Peccato!
    sono ancora su Feisty

    Commento di Maurizio — novembre 14, 2007 @ 10:49 pm

  26. [...] assoluta del mio desktop è la presenza di Compiz Fusion che va a sostituire la tanto amata Beryl Telperion Edition, Compiz Fusion di cui abbiamo varie [...]

    Pingback di Ubuntu 7.10 e le mie scelte [repository,compiz,audio….] « OpenMania — novembre 18, 2007 @ 3:15 pm

  27. Grazie mille
    tutto funzionante

    Commento di Corrado — dicembre 14, 2007 @ 10:50 am

  28. scusatemi ma io ho un computer con tecnologia amd64 dove posso trovare dei pacchetti come questi per gli amd64????

    Commento di Qualcuno — gennaio 13, 2008 @ 9:55 pm

  29. Grande telperion!!!! Finalmente appena avrò un pc serio con gutsy (purtroppo ora sono costretto a girare su windows… Sigh…:( ) potrò assaporare tutto il potere di Beryl!! Compiz-fusion in effetti non è la stessa cosa… Preferisco notevolmente Beryl!! Ottimo lavoro!

    Commento di Alex Florenti — gennaio 26, 2008 @ 9:06 pm

  30. Però avrei una domandina… Sì possono avere installati Compiz e questo pacchetto di Beryl su Gutsy Gibbon insieme?

    Commento di Alex Florenti — gennaio 27, 2008 @ 6:43 pm

  31. Alex: dovrebbero funzionare solo emerald si sovrappone, ma i 2 “dovrebbero” essere compatibili quindi installane solo uno dei 2.

    Commento di telperion — gennaio 27, 2008 @ 6:46 pm

  32. ok grazie mille! Adesso stò diffondendo la dottrina di ubuntu ad una mia amica, gliel’ho appena installato e questa informazione mi sarà molto utile! grazie! :-)

    Commento di Alex Florenti — gennaio 27, 2008 @ 6:52 pm

  33. Un’ultimissima cosa: se aggiungo Beryl all’avvio dà qualche problema?

    Commento di Alex Florenti — gennaio 27, 2008 @ 7:12 pm

  34. Buonasera Telperion! Ho visto che hai zelantemente fatto alcuni plugin per Beryl su Feisty come screensaver e widget, ma su Gutsy funzionano? E se non funzionano, ne farai mai per Gutsy?

    Commento di Alex Florenti — gennaio 30, 2008 @ 7:50 pm

  35. @Alex: no non funzionano su gutsy e non ne compilo altri.

    Commento di telperion — gennaio 30, 2008 @ 8:42 pm

  36. Ma hai fatto anche la versione di Beryl per i686??

    Commento di Julian Frickleton — febbraio 11, 2008 @ 8:17 pm

  37. @Julian Frickleton:
    in Ubuntu c’è la versione -i386 per tutte le architetture 32 bit
    e la -a64 per le architetture intel/amd 64 bit.
    Non esistono versioni i686.

    Commento di telperion — febbraio 11, 2008 @ 8:43 pm

  38. Va bene… Alla luce di questa informazione… Hai fatto anche la versione a64?

    Commento di Julian Frickleton — febbraio 14, 2008 @ 5:43 pm

  39. Ok mi sono risposto da solo… Cercando in google con a64 ho trovato il link al tuo sito… Grazie lo stesso!

    Commento di Julian Frickleton — febbraio 14, 2008 @ 5:44 pm

  40. @Julian Frickleton: la versione -a64 è per Ubuntu 64 bit, se invece hai Ubuntu 32 bit devi usare la -i386 a prescindere dal fatto che la CPU sia una 64 bit, devi vedere la distribuzione se è a 32 o 64 bit.

    Commento di telperion — febbraio 14, 2008 @ 6:07 pm

  41. Ok perfetto… Ma… Una domanda: come si fa a mettere Beryl all’avvio? Bisogna creare uno script?

    Commento di Julian Frickleton — febbraio 14, 2008 @ 6:13 pm

  42. Aggiungi il comando

    beryl-manager

    in sessioni se hai gnome, se hai kde devi mettere il comando o il link simbolico in ~/.kde/Autostart

    Commento di telperion — febbraio 14, 2008 @ 6:27 pm

  43. Grazie mille!

    Commento di Julian Frickleton — febbraio 14, 2008 @ 8:27 pm

  44. @Telperion
    sono per caso in programma i pacchetti per hardy?

    Commento di Algol — marzo 25, 2008 @ 5:19 pm

  45. @Algol:
    magari appena esce la rc di Hardy faccio un tentativo di compilazione e vedo se funziona.

    Commento di telperion — marzo 25, 2008 @ 6:45 pm

  46. @Telperion
    grazie mille :D

    Commento di Algol — marzo 25, 2008 @ 7:27 pm

  47. ciao…ho installato tutto….un’informazione…come posso abilitare gli effetti???il cubo ecc?? di prego aiutami!!!!!1

    Commento di Dany91kr — aprile 13, 2008 @ 1:40 pm

  48. ciao Telperion..
    sono un pivellissimo di linux..
    volevo installare beryl e seppur seguendo la tua guida non riesco proprio..
    una volta posizionatomi sulla cartella su cui estraggo i file il comando sh beryl-svn.sh non funziona
    la risposta da terminale è cannot open file..
    mi manca qualche pacchetto .. oppure sono proprio io che sono una cippa??

    Saluti

    Diacono Frost

    Commento di Diacono Frostl — maggio 3, 2008 @ 5:09 pm

  49. @Diacono Frostl
    intanto questi sono i pacchetti per Ubuntu 7.10 Gutsy
    Se hai installato Ubuntu 8.04 Hardy devi installare
    quelli segnalati nel commento 50.

    In ogni caso in questo commento c’è una spiegazione più dettagliata

    http://telperion.wordpress.com/2008/04/20/a-qualcuno-piace-beryl-pacchetti-i386-per-kubuntu-hardy/#comment-7895

    Ovviamente se installi i pacchetti per Gutsy (quelli di questa pagina)
    devi usare il nome della cartella scompattata.
    Il resto è uguale.

    Commento di telperion — maggio 3, 2008 @ 7:48 pm

  50. Io ho ubuntu 9.10, e sarei curioso di provare beryl…il problema è che ho architettura amd64!! dove li trovo i deb compatibili??

    Commento di Glaedr — gennaio 4, 2010 @ 2:54 pm


RSS feed dei commenti a questo articolo.

The Rubric Theme Blog su WordPress.com.

Iscriviti

Ricevi al tuo indirizzo email tutti i nuovi post del sito.

Unisciti agli altri 31 follower

%d blogger cliccano Mi Piace per questo: